Wireless issue...

Discussion in 'MacBook Pro' started by paulgerr, Aug 29, 2008.

  1. paulgerr macrumors newbie

    Joined:
    Jul 17, 2008
    #1
    Note: There is a summed up version of this post after the line break, though I really would prefer if you read the entire post.

    I bought a new Macbook Pro, the current model, from Apple two weeks ago (19 days to be specific) for college. It preforms wonderfully, and I'm very glad I made the choice to purchase one.

    However, I have been experiencing a pretty major problem since a few days after I started using the notebook.

    Basically, the mac appears to be crashing my wireless network completely when it demands even a moderate amount of data. But here's the odd part. It only occurs on the wireless when using Airport.

    I have a Netgear WGT624 802.11 a/b/g router. It is connected by Ethernet to my home computer, and wireless connected to my sisters laptop (not a Mac), both my father's and my own iPhone, an iPod touch, and my notebook. The router is up to date in terms of firmware.

    I can replicate the issue quite easily, so I feel I have a pretty good understanding of how this happening, but not why or how I can correct it, at least without causing separate comfort issues.

    The problem occurs, as I mentioned, when I put the connection under sort of load. For example, the easiest way for me to replicate the problem is to zoom in or zoom out on Google Maps, as it loads a large amount of data to form the maps (this is not limited to Google Maps in any way, but extends to just random pictures, Skype, youtube, etc.). In nearly every attempt thus far, upon changing the zoom causes the network to stop responding with the map partially loaded (some squares never render). I can't load anything on another webpage, and basically all Internet connectivity stops. However, the laptop still says I'm connected to the network under Airport. On my Ethernet-connected computer, the network is also down, though it also believes to still be connected to the network. The router itself shows no change from when it is transmitting data compared to when it is not, and the Link light on the modem shows that it is connected to the router.

    I've gone into Network Preferences and tried using "Assist Me..." and Diagnostics. Upon entering the information to join the network (it is a hidden network using WPA Personal encryption), the connection test shows that it has failed and that it cannot connect to the chosen hidden network. However, the status symbols on the left sidebar tell a different story, and show that the Airport, Airport Settings, Network Settings, and ISP are all responding normally (green icon), while the Internet and Server change from the yellow icon to the red icon, noting a problem. If I turn off Airport and turn it back on, it will not rejoin the network that is supposedly still working, and displays that all the checkpoints in the Diagnostics as Failed.

    The computer that is tied by Ethernet experiences no such problems. It can stress the network as much as possible and not cause the network to crash. When the network is downed by my Mac (assuming that's what is happening), it has no connectivity at all, though still displays that it is connected. None of the iPhones (both are originals running the latest firmware 2.0.2), the iPod Touch, and my sister's laptop cannot connect to the wireless network. Basically, our entire network goes down when my Mac causes it to go down.

    We did have some initial problems with the network connectivity with my Mac, particularly being that because we had so many devices logging in and out, we would occasionally occupy the same IP address, which would cause my Mac to drop the network for a moment and then rejoin with a different IP. This was remedied by telling the router to reserve a high IP address (192.168.0.40 to any who care), and my setting my Mac's Airport settings to manually join the specific IP, use the correct subnet mask, and DNS server, and router address. I have checked this issue using DHCP and DHCP with manual address as well and the same problem occurs. A separate but very insignificant issue (from what I can tell), is that my notebook would not take the designated IP address the router is telling it to take under DHCP automatically. For whatever reason, it was choosing the lowest-numbered available address at the time, and when the device that came on with that designated IP address came on, it would get kicked off. Setting the IP address and everything manually removes this problem, but it is still there if it has any bearing on my main issue.

    The really weird thing is that when I connect my laptop to the router via Ethernet, everything works perfectly fine. I can stress the network to no end, and it will not knock out the network. The Ethernet connection information (IP, subnet, DNS server, router address) were entered in manually to get it to work (ties back to that smaller issue just mentioned), but it still works without issue. This is where the comfort problem comes in, as I could just keep myself connected to the network via Ethernet, but that reduces the portability aspect of the notebook ever so slightly [sic].

    To fix the problem, I have to restart the router (unplug and plug it back in), which has become immensely tiresome. As a side note, this could be in no way be affected by a lack of signal strength; the router is less than a foot from the router when I normally use it, and it has amazing signal strength (3-5 bars) throughout my house, or at least wherever I'm likely to use my Mac.
    ___________

    To sum this post up, my Mac is killing my network when it uses the wireless and puts a very insignificant amount of load on the connection. The router itself refuses all transmissions inbound, Airport on and off. The network is cut off to all wireless connections, and wired connections. On a device such as an iPhone, there is no network listed as available when this problem occurs. This problem does not occur when connected to the network by Ethernet. The network settings have been set manually and correctly. There has been a previous issue that was resolved by putting the network settings in manually. I can replicate the problem easily, and it occurs a few times throughout the night. The Mac is less than 3 weeks old and the current revision of the Macbook Pro. The problem occurs on and off charge.

    Any help or insight at all is appreciated. My father and I are both computer-savvy (though my father is unfamiliar with Macs). My father is a system administrator for a company and works with routers and computers constantly. I have taken Cisco networking classes and I am very capable of working with routers and such.

    Thanks for any help ^_^.
     
  2. merl1n macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #2
    Very long post...

    It sounds like the wireless circuitry in the router is dropping out and then back on under load. It shouldn't do that. You may want to try another router.

    I've seen this in the past with Linksys (now Cisco) routers. I ran into this a few weeks ago with my sister's Linksys router. I replaced it and she has had no problems since.
     
  3. paulgerr thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #3
    Yeah, I tried to explain as much as I could about the problem to see if it set off any bells for someone.

    I'm really not sure if it is the router really, as it never does this if I put it under stress from my iPhone, and my sister hasn't had any such problems on her laptop (besides poor reception).

    It just seems weird that the Mac is telling the doing something to the router over wireless that's telling it to cut off all network connectivity, but when its wired, the problem doesn't occur.
     
  4. TEG macrumors 604

    TEG

    Joined:
    Jan 21, 2002
    Location:
    Langley, Washington
    #4
    Your router is broken. Purchase a new one. I would suggest AirPort Extreme, TimeCapsule, or AirPort Express.

    TEG
     
  5. havenly007 macrumors newbie

    Joined:
    May 20, 2009
    #5
    I am having the very same problem...except I have a Netgear WGT624 and I have been going to hulu and attempt to view a commercial to stimulate the problem (also occurs via software updates and others). Anyway, its all the same symptoms; works on pc laptops, works fine when connected via ethernet, etc.

    I have a post elsewhere on this forum and have tried many things in my attempt to fix it (Repair permissions, decrease security settings, PRAM, update router firewall, turn off IPv6 and more) all to no avail.

    Please, please let me know (post here) if you find a solution...or whether the only solution was to purchase a new router. Thanks!
     
  6. paulgerr thread starter macrumors newbie

    Joined:
    Jul 17, 2008
    #6
    Unfortunately, my solution was a new router, we never could figure out what caused the problems (besides the router being ridiculously old).
     
  7. havenly007 macrumors newbie

    Joined:
    May 20, 2009
    #7
    Ok, thanks! It's good to know that that fixes it...I didn't want to buy a new router and then still have the problem. But, given all my fruitless attempts to fix it and the similarity of my problem to yours that may be the best option. Thanks for letting me know.
     
  8. Runt888 macrumors 6502a

    Joined:
    Nov 17, 2008
    #8
    +1 for needing a new router, and for the recommendations. I struggled with multiple Linksys and Netgear routers for years (I actually had an identical problem as what you're describing, but it only occurred with my Windows laptop). Since I switched to an Airport Extreme, I've had absolutely no problems. It's been running for almost a year without having to be reset once.
     
  9. J&JPolangin macrumors 68030

    Joined:
    Jul 5, 2008
    Location:
    Thule GL @ the TOW
    #9
    ...what did you get for your new router?

    I have a Linksys WRT54G that I donated to the office I work in, still working fine... a WRT54GS that is now in the box (as a spare should anything happen to my current router) and my SDB AEBS that's a fantastic router...

    I was a big fan of netgear products but they only seemed to be good for about 2 years living in Japan with the different Mhz on the power outlets (even though the power supplies are supposed to auto switch)...Linksys has been good but this apple unit will probably be my favorite.
     
  10. havenly007 macrumors newbie

    Joined:
    May 20, 2009
    #10
    Just thought I would update. I ended up buying a new router (splurged on a Time Capsule) and it fixed the problem.
     

Share This Page