Wireless Issues - A Mac Problem

CFoss

macrumors 6502
Original poster
Feb 26, 2011
271
1
For the past year, my family have loved their MacBook Pros. It does everything they want, but one issue has plagued both MacBooks: The wireless connection.

Every ten minutes or so, the Internet will stop working. Airport still detects both networks in the house (and is in fact, still connected), but the Internet freezes.

The only fix to this problem is by turning Airport on then off... until the problem occurs again ten minutes later. The only reliable system in the house is the Mac Pro, which is connected via wire. When I do use the Wireless, it starts having problems.

Now, I would have stated it's a Wireless Router issue... but remember, we have used several routers over the years. That, and Airport detects them - The Internet just doesn't work. Which leads me to believe that it has to be an issue with Airport or OS-X itself. The Windows laptop seems to do fine. Admittedly, the Playstation 3 has difficulties finding the network. But it's fine once it makes a full connection.

My point is this: Does anyone else experience the same issues with their Macintosh products? And if so, did you ever find a solution?
 

AFPoster

macrumors 68000
Jul 14, 2008
1,526
103
Charlotte, NC
This is a known issue and Apple is working on a fix (hopefully Lion). Other forum members have talked about this including me. If it goes out that frequently though take your Mac back to Apple for another. Mine is like 1x a week and all I need to do is reclick my wifi network and I'm good to go again.
 

zettahertz

macrumors newbie
May 25, 2011
16
0
maybe you can try changing the channel on your router for the wifi. A lot of people just leave it on the default 11, and can cause interference. You can check this by holding option and click on the wireless icon on the top right, then mouse over each wifi network.
 

CFoss

macrumors 6502
Original poster
Feb 26, 2011
271
1
Can't - One of them is tied exclusively to an independent system. Even then, having the router off doesn't make a difference.
 

palpatine

macrumors 68040
May 3, 2011
3,130
45
no problems here. this suggests either a problem with the computer, or with certain types of routers. i doubt it is any setting inside your computer.

you could try out a few other routers (ask some friends if you can borrow theirs). there might be a brand, configuration, or capability that makes a difference somehow. if this doesn't solve the problem, you could go to apple and get a new computer. the problem with going to apple is that you might just end up with another computer having the same problem.
 

rcr

macrumors member
Jul 27, 2010
67
0
Bristol
Called Apple Care about this issue, they were friendly and clear in their instructions. I moved the system configuration folder out of preferences onto the desktop. Restarted. Tried the internet; it was working. Then trashed the old configuration folder.

Go>Computer>Macintosh HD>Library>Preferences>SystemConfiguration

So far so good, but the problem was intermittent, so will see. Maybe you can try this, hope it helps.
 

rcr

macrumors member
Jul 27, 2010
67
0
Bristol
Update is, it seems to have worked. Fingers crossed, no more problem.
Unfortunately the problem returned and has gotten even worse. I'm having to have my computer taken away for analysis and repair.
 

negativzero

macrumors 6502a
Jul 19, 2011
564
54
Unfortunately the problem returned and has gotten even worse. I'm having to have my computer taken away for analysis and repair.
Some things you can try doing.

Change the broadcast channel on your router.
Activate the 40MHz channel on your router.
Switch to the 5GHz band on your router.

Personally, the last step is the one that worked for me. I used to have lots of problems with the WiFi at home till I realized there were more than 30-40 hotspots in the vicinity of my home, so the only way to fix that problem was to switch to the 5GHz band, after which I never had any inter fence again, and it was all smooth sailing.
 

rcr

macrumors member
Jul 27, 2010
67
0
Bristol
Some things you can try doing.

Change the broadcast channel on your router.
Activate the 40MHz channel on your router.
Switch to the 5GHz band on your router.

Personally, the last step is the one that worked for me. I used to have lots of problems with the WiFi at home till I realized there were more than 30-40 hotspots in the vicinity of my home, so the only way to fix that problem was to switch to the 5GHz band, after which I never had any inter fence again, and it was all smooth sailing.
I've tried changing channels and it has no effect. Not sure if my router allows me to change the Hz of the channel?
 

rcr

macrumors member
Jul 27, 2010
67
0
Bristol
After sending off my computer and them offering to replace my wireless card incase, but finding nothing wrong with it I got my iMac back without change. The problem persisted.

I am now almost certain it is something to do with my BTHomeHub 2.0 rather than the iMac. I seem to remember using a belkin b/g/n wireless receiver and having similar dropouts on a Windows PC I was using.

I've reconfigured the router to b/g instead of b/g/n. Running smoothly so far, waiting to see if problem returns.

Fingers crossed.
 

aidan257

macrumors newbie
Aug 7, 2011
9
0
Peterborough, UK
I seem to have a similar issue with my iMac G5 2ghz. It seemed to happen more frequently in Leopard then it did in Tiger. But because Tiger was no longer supported for various updates i binned Tiger & decided to live with the drop outs.
TBH lately it hasn't happened as often as it used to. I still have absolutely NO idea why it happens. I've tried various things to sort it but they didn't make a difference.
Since my house mate has been away it hasn't happened for the last couple of days, so i have put it down to some kind of interference, maybe some software he was using on his laptop was causing it to drop out i don't know.
Hopefully when i get my MBP 13" i don't have these sort of issues.
 

rcr

macrumors member
Jul 27, 2010
67
0
Bristol
After sending off my computer and them offering to replace my wireless card incase, but finding nothing wrong with it I got my iMac back without change. The problem persisted.

I am now almost certain it is something to do with my BTHomeHub 2.0 rather than the iMac. I seem to remember using a belkin b/g/n wireless receiver and having similar dropouts on a Windows PC I was using.

I've reconfigured the router to b/g instead of b/g/n. Running smoothly so far, waiting to see if problem returns.

Fingers crossed.
Problem still happens, oh well... the search goes on. Will be taking iMac into the studio soon, so hopefully will avoid this issue when I'm able to keep it plugged in to the internet.
 

CortexRock

macrumors 6502
Dec 3, 2006
413
0
Canterbury, England
I've tried changing channels and it has no effect. Not sure if my router allows me to change the Hz of the channel?
I think I read somewhere that the 5GHz channel on the Airport Extreme isn't available in the UK due to the frequency being used by 'other' agencies. Can someone confirm? :confused:
 

Benbikeman

macrumors 6502a
May 17, 2011
616
0
London, England
5Ghz is available in the UK, but be aware that it is pretty much line-of-sight: it's rubbish at going through walls. 2.4Ghz is the better choice if you want to access a router from other rooms in the house.
 

alFR

macrumors 68020
Aug 10, 2006
2,457
471
5Ghz is available in the UK, but be aware that it is pretty much line-of-sight: it's rubbish at going through walls. 2.4Ghz is the better choice if you want to access a router from other rooms in the house.
That's weird, because I can connect to my 5Ghz N network throughout the house (router is in an upstairs bedroom) and at the bottom of the garden as well... Mainly stud walls, mind you, so YMMV if you're in an entirely stone built house or something.
 

GuitarG20

macrumors 65816
Jun 3, 2011
1,020
1
I have a stone walled house and I am able to walk my macbook almost half a block down the street before it has any issues...

Even right now I am sitting 2 stories above the router and it's still reporting full bars.
 

rcr

macrumors member
Jul 27, 2010
67
0
Bristol
Problem still happens, oh well... the search goes on. Will be taking iMac into the studio soon, so hopefully will avoid this issue when I'm able to keep it plugged in to the internet.
Okay, the problem is much less frequent setting the router to b/g bands. Maybe once or twice a day now. I get the impression I could only improve on this with an Airport extreme or express.
 

jbg232

macrumors 65816
Oct 15, 2007
1,141
2
While expensive, if the airport extreme would fix the problem it would be worth it imo. Why don't you buy one, test it out for <14 days and if it doesn't change anything return it.
 

Steve's Barber

macrumors 6502a
Jul 5, 2011
774
0
Even right now I am sitting 2 stories above the router and it's still reporting full bars.
I've had full bars with Airport reporting that all is fine but can't load a web page or use Mail.

Something is screwy on the OSX side. Lion didn't fix it either. It all started with 10.6.8 for me (I think) and I suspect the issue got ported over to Lion as well. It's most likely one of those "gremlin" issues that need 2 or 3 conditions to occur simultaneously because it's so intermittent.

But this problem does exist and the remedies given so far are not necessary for Windows machines in my house. They connect fine and don't skip a beat.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.