Wireless issues in Windows 7 on MBA

Discussion in 'Windows, Linux & Others on the Mac' started by debrett, Sep 17, 2012.

  1. debrett macrumors newbie

    Joined:
    Sep 17, 2012
    #1
    Hi,
    So i have a MBA 2011 model running purely windows for work purposes.
    Just lately i have been experiencing intermittent wireless issues where all connections will just drop out. i then have to disable and re-enable the wireless to get it to work again. It is not the router as i have experienced this in several different locations. So my question is.. firstly has anyone else had this issue.
    Secondly where on God's earth do i find the updates for the wireless drivers? Can i go to the manufacturer of the wireless cards website and download the new fresh drivers? The issue is i never used bootcamp properly when i installed it i dont think, is it right you should have some kind of bootcamp install on the mac you can get drivers and updates from? Because if this is the case i dont have anything like that installed.. Please can someone help me out, it's much appreciated as im stuck in a deep hole here.
    Cheers
     
  2. SyncFx, Sep 17, 2012
    Last edited: Sep 19, 2012

    SyncFx macrumors member

    Joined:
    Feb 27, 2011
    Location:
    Vancouver, BC
    #2
    Hey debrett,

    I've been having these exact same issues as you since I installed Windows 7 on my Late 2010 Macbook Pro last year. However recently after upgrading to Mountain Lion last night and doing a fresh install of Windows 7 my wireless issues have increased ten fold.

    I've update my drivers via http://www.reviversoft.com/driver-reviver/. You have to purchase a license to install. However the issues are still not cleared but I suggest having all your drivers up to date anyways.

    I've been searching since I've gotten these issues last year but since it's increased lately I will search till I find it and post it here when I have something!

    EDIT!

    After looking around I've found even more updated drivers then the one Driver Reviver installed.

    http://www.broadcom.com/support/ethernet_nic/downloaddrivers.php Here are the drivers for the NetXtreme Gigabyte Ethernet one.

    And here is the list of the the wifi drivers http://www.pcpitstop.com/drivers/download/Broadcom~802.11n~Network~Adapter.html

    You'll have to search for the driver. I downloaded one that says it's for HP laptops but it installed successfully with no issues yet.

    EDIT 2:

    Simple web browsing the problem seems fixed. However everytime I game it will occasionally disconnect still, after driver updates. Playing a 35 minute of League of Legends it disconnected twice. The network will drop, but it doesn't know it yet(It thinks it's connected). I have to disconnect from WiFi until I hear Vent finally disconnect to reconnect.

    EDIT 3:

    I have seem to have a fix, I suggest doing this both in OS X and in Windows.

    In terms of myself after installing OS X Mountain Lion, it's been reported that numerous amounts of people are having issues with WiFi dropping randomly, something I never got in OS X until Mountain Lion. So I searched for that first. I found a fix in which you have to change your MTU settings in WiFi to a lower value.

    Mac:
    To do this in OS X Go to your network settings and select WiFi and go to advanced, go to the hardware tab and you'll see the option to change MTU. I set mine to 1420. *Correct me if I'm wrong, I'm currently in Windows.

    Windows:

    In Windows it's a bit more difficult but worth it. After playing a hefty long Battlefield game I didn't disconnect once. 50+mins.

    Go to start menu and type in regedit and hit enter.

    Go to HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> services -> Tcpip -> Parameters -> Interfaces.

    Now you should see a few folders with various amounts of numbers and letters in {}. Find the folder that lists an IP address. Such as DhcpIpAddress or DhcpServer.

    Once you found that folder right click on an empty area select New DWORD (32-bit) Value. Name it MTU. Right click it and select Modify. Make sure to select Decimal and type in a value NO LESS THAN 1500. I think its already set to 1500. Save it or press Ok and restart your computer. As I said earlier I set mine to 1420 and no issues thus far.

    Hopefully this fixes this for you.
     

Share This Page