Resolved Wireless Keyboard page up/page down not working; OS X sees it as pc keyboard?

Discussion in 'Mac Accessories' started by jbbythebch, Sep 17, 2011.

  1. jbbythebch, Sep 17, 2011
    Last edited: Sep 21, 2011

    jbbythebch macrumors newbie

    Joined:
    Sep 17, 2011
    #1
    I had a standard pc keyboard connected to this MacBook Pro via a KVM switch (keyboard-video-mouse) when using it at my desk. When I connected the Apple Wireless Keyboard to the MacBook, this USB keyboard was still connected.

    When pressing fn-arrow up, or fn-arrow down, the screen just goes up or down one line at a time, exactly like if the fn key was not used, and the arrow keys were used by themselves. This happens with different users, and with different applications (test with Adobe Reader, Safari, Firefox, Finder, Preview, etc.).

    When viewing the Keyboard Viewer, the keyboard initially comes up as a keyboard layout that looks like the MacBook Pro keyboard and the Wireless keyboard. However, as soon as I press any key on the keyboard, the layout expands to show a full keyboard with the number pad at the right.

    The function keys act like they are standard pc keyboard keys. For example, F11 (without the fn key pressed) doesn't decrease the volume, but shows the desktop.

    The Wireless Keyboard seems to be fine itself, as it works normally on another almost identical MacBook Pro we have.

    Resolution attempts have included removing the keyboard from BlueTooth devices and reconnecting it; removing the "/Library/Preferences/com.apple.Bluetooth.plist" file, and have not resolved this yet.

    My guess is there is a fairly simple way to delete the configuration of this keyboard and start over connecting it to the MacBook without the KVM connected, but I have not found that method yet.

    Any insight would be appreciated.

    Thanks in advance.

    - OS X 10.6.7
    - MacBookPro5,5
    - Apple Wireless Keyboard (aluminum 2009)
     
  2. jbbythebch thread starter macrumors newbie

    Joined:
    Sep 17, 2011
    #2
    Genius Bar could not resolve this (in one appointment)

    I thought I'd give the Genius Bar a shot at this problem, and took the MacBook & Wireless Keyboard into my local Apple store late yesterday. The tech had been there about 3 years, and seemed knowledgeable. He'd never seen this before and didn't have any idea what was causing it. He said I could check it in so they could spend more time on it later, but I can't leave it there that long.

    Next up...probably restoring from my Time Machine backup.
     
  3. jbbythebch thread starter macrumors newbie

    Joined:
    Sep 17, 2011
    #3
    OS X Update from 10.6.7 to 10.6.8 resolved the issue.

    I resolved this keyboard issue by updating OS X from 10.6.7 to 10.6.8. It works fine now.

    Details:

    I tried restoring the entire drive to a few weeks prior to buying the Wireless Keyboard - didn't fix it.

    I tried deleting the keyboard (and Trackpad) in system preferences > bluetooth; deleting the preference file, com.apple.bluetooth.plist; then resetting the PRAM and NVRAM; and removing the batteries from the wireless keyboard before reconnecting the keyboard - didn't fix it.

    I had not wanted to run the 10.6.8 update, as I had found no information on it containing any related fixes, and I was guessing I'd have to revert back to a prior Time Machine backup anyway. However, the "almost identical" MacBook Pro the keyboard worked with was running 10.6.8. And, the tech at the Genius Bar wanted to install 10.6.8 (not that he was sure it would resolve it, but it's just standard procedure). So, I finally decided to go ahead and install 10.6.8, and it works fine now.
     

Share This Page