Wireless Mighty Mouse Not Syncing with iMac

Discussion in 'iMac' started by powerhouse7, Feb 13, 2010.

  1. powerhouse7 macrumors regular

    Joined:
    Oct 21, 2009
    Location:
    Canberra, Australia
    #1
    On occasion my Wireless Mighty Mouse, that is paired with my iMac, doesn't sync. It most often occurs when i turn on my computer and then turn on my mouse after startup. When this happens, my iMac stops listing my mouse as a paired device and in order to get it to work, i have to plug in a wired mouse and resync the might mouse.
    I'm using a white 5,1 iMac with Mac OS X Leopard 10.5.8. The problem has happened since I first bought the mouse on the christmas of 2008.

    Does anybody know what might be causing this or how to fix the problem?
    Any help would be most appreciated!
    Thanks very much in advance :confused: :apple:
     
  2. cocky jeremy macrumors 68040

    cocky jeremy

    Joined:
    Jul 12, 2008
    Location:
    Columbus, OH
    #2
    I've got no help to offer, but i can bump this thread by saying that mine occasionally drops, too. Sometimes it re-connects itself and other times i have to use my Logitech to disconnect, then re-connect again. (It still says connected but won't move)
     
  3. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #3
    Don't switch off the wireless mouse, just keep it on. If it doesn't pair, switch it off (slide the thing up) and then turn it on again and wait if it connects
     
  4. powerhouse7 thread starter macrumors regular

    Joined:
    Oct 21, 2009
    Location:
    Canberra, Australia
    #4
    I have of course tried the good old turn off then on trick, but to no avail. I think the issue is related to the fact that the OS doesn't 'remember' my mouse.
     

Share This Page