wireless mighty mouse won't click

Discussion in 'Mac Accessories' started by aureiden, Dec 27, 2007.

  1. aureiden macrumors member

    aureiden

    Joined:
    Mar 7, 2007
    Location:
    USA
    #1
    The pointer will move, but sometimes, neither clicker will click, and I end up having to disconnect and connect again. Does this happen to anyone else? Any solutions? Oh, and whenever I move my Macbook to a different room, the connection is lost, whereas the wireless keyboard connection remains intact. This mouse is annoying the **** out of me. I'm not even gonna start about the scrolling problem...
     
  2. macleod199 macrumors 6502

    Joined:
    Mar 10, 2007
    #2
    Have you tried changing the batteries? Otherwise you might just have a flaky unit.
     
  3. atthecross macrumors 6502

    Joined:
    Jun 8, 2007
    #3
    ok, this post appears and then I start to experience the exact same problem.

    Yes, my mouse batteries are good.

    happened last nite, can move the mouse but can not click on anything and again this morning. I have to take out my old wired mouse and pair my mouse again.

    anyone else or just me and the original poster?

    Mighty mouse ~2 months old
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    Interference from microwave, cordless phone, baby monitors, etc.?
     
  5. atthecross macrumors 6502

    Joined:
    Jun 8, 2007
    #5
    hmmm cordless phone is 5.8ghz so out of BT freq band. almost had me with the cordless though, cause it was sitting on my computer desk when both lock up occurred. but will move it just in case.

    other than that, nothing added to my home and as far was I know, no new babies in the neighbor hood.

    microwave has always been there, but both lockouts happened with no microwave activity.
     
  6. toomanyipods macrumors newbie

    Joined:
    Sep 27, 2007
    #6
    Same thing here

    I'm getting the same behavior. Batteries test fine. Just stopped taking any click whether it's button 1, 2, 3, or 4. But it moves without a hitch.

    It's doesn't lose connection, in fact, when I turn the mouse off, I see connection lost for the first time. When I turn the mouse back on, it starts to click just fine.
     
  7. Chatham macrumors newbie

    Chatham

    Joined:
    Aug 28, 2006
    Location:
    NY
    #7
    Not so mighty mouse

    I am experiencing the same problem, my wireless mighty mouse was working fine, then just recently it has been disconnecting itself constantly,the batteries are fully charged. I have resorted to plugging in my old wired mouse.
     
  8. JSchwage macrumors 6502a

    JSchwage

    Joined:
    May 5, 2006
    Location:
    Rochester, NY
    #8
    Just started having the same problem with my Mighty Mouse. Maybe it's something wrong with Leopard? What version of OS X is everyone else using that's having this problem?
     
  9. phas3 macrumors 65816

    Joined:
    Oct 5, 2008
    #9
    bump this post i just had this problem come up
     
  10. Edv macrumors newbie

    Joined:
    Nov 22, 2008
    Location:
    Bozeman, Montana
    #10
    Me too, more info

    This clicking-not-registering with the computer just started happening for me too -- for the first time. A wired mouse works, though.

    I did a restart and turned the wireless Mighty mouse on and then off -- it reconnected. Then all has been working well so far.

    In another forum somebody reported a wireless mouse clicking, but not tracking. He found that a slight film on the metal contact point inside the mouse where the battery touches was the problem. He said it removed easily with a paper towel and mouse tracked fine again. May be related to click problem too?

    PS To keep weight of mouse low, I use just one battery. One is all that is necessary, as pointed out in the manual.

    Edv
     
  11. ksb43 macrumors member

    Joined:
    Oct 15, 2008
    #11
    I have this problem a few times a month. Every time I have to flip the switch on the bottom of the mouse on and off to get it working again. Seems like a faulty product to me.
     
  12. dalgraphx macrumors newbie

    Joined:
    Jan 8, 2009
    #12
    Same here...

    I just started having this problem today. I've used the mouse for about a year and a half without incident.

    I've found that cycling the power on the mouse gets me back in business. Very annoying and frustrating.
     
  13. ehtaft macrumors newbie

    Joined:
    Jan 23, 2009
    #13
    Same Problem

    Hey everyone,
    I have the same problem with my Mighty Mouse. The battery is full, and just turning it off and on has only worked for me once. Restarting doesn't help.
    Nope, the only fix for me is to wait a few minutes for it to fix itself, so I'm not sure it's the same problem. Either way, it's really bizarre and annoying, so anyone who has any clues, please post! I just hope it doesn't involve taking my mouse apart. I would never be able to put it back together.
     
  14. creationmachine macrumors newbie

    Joined:
    Jul 17, 2009
    #14
    I was having this problem. If you take off the battery cover there is a - I am assuming - reset button below the optical window. Press it for a few seconds. It worked for me.
     
  15. sk8mash macrumors 6502a

    sk8mash

    Joined:
    Dec 1, 2007
    Location:
    England
    #15
    I have this to occasionally. Just turn it off and on again.
     
  16. Mwright macrumors newbie

    Joined:
    Oct 23, 2007
    #16
    no click wireless

    I have this problem periodically. The cursor moves but no clicking. I have two of these mice and one quit working when it was a little over a year old so I use the wired mouse. It always works. The other works for a couple of months and then acts up as described. Turning it off and back on corrects the problem for a while.
     
  17. sennejm macrumors newbie

    Joined:
    May 26, 2008
    #17
    prefpane

    I had previously contacted AppleCare about this issue, and they said the problem likely had to do with a corrupted prefpane file. They had no reason as to why the problem occurred. The simplest solution is just to turn the mouse off, wait for "connection lost" to flash on the screen, and then turn the mouse back on.
     
  18. iKriz macrumors newbie

    Joined:
    Apr 26, 2006
    #18
    I have exactly the same problem, Mouse can move and scroll it just wont click anything... eventually i thought wheres my tocuh pad i'll give that a go... after finding out my touchpad was buried under everything and thus being pressed... (doh) problem fixed

    As for being a "mighty" mouse functionality of the hardware is fine for me works like a charm. :)
     

Share This Page