wireless mouse does not work well on OSX

Discussion in 'MacBook Pro' started by schmintan, Jun 25, 2007.

  1. schmintan macrumors regular

    Joined:
    Mar 1, 2007
    #1
    i have a wireless mouse ive used for a year or so with windows with no problems. i have windows on a partition on my MBP and the mouse works well on that also. when i have OSX open though , the mouse works, but is very jumpy, slow, and unresponsive. i have to give an extra firm push on the mouse buttons to get them to work when in OSX. i have played with mouse settings to no avail. is there anything i can do to remedy this, without buying a new mouse?
     
  2. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #2
    You can start by telling us what Mouse it is (I am assuming this is a USB mouse and not BT). And is the receiver in clear view? I have an MS Lasermouse and it works great with my iBook. I recommend using USBOverdrive as well, it gives you plenty of options on tweaking your mouse performance.
     
  3. schmintan thread starter macrumors regular

    Joined:
    Mar 1, 2007
    #3
    its a microsoft mouse, the reciever is about 15 centemeters away from the mouse, and the mouse has brand new batteries. the reciever hooks up to the laptop via usb. here is the exact mouse here:

    http://www.amazon.com/Microsoft-Wir...8?ie=UTF8&s=electronics&qid=1182846742&sr=8-3

    I know its a MS Mouse, but if Microsoft decided to make it not work with OSX, then it wouldnt work at all, rather than the way it works now, jumpy and well, like an old, dirty ball mouse.
     
  4. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #4
    Well, I don't see how USB Overdrive will fix this problem but its still worth a shot. Kind of a shame, looks like a cool mouse. You're gonna have to resort to some googling to find some answers, cause I got nothing nor have I heard of this issue before.
     
  5. agore macrumors member

    Joined:
    Oct 26, 2006
    #5
    No such problems here on a new SR MBP. I'm using a wireless Mighty Mouse. It works perfectly in OS X and in virtual Windows XP and Ubuntu Linux images on the same machine.
     

Share This Page