Wireless mouse troubleshooting problem...

Discussion in 'Mac Basics and Help' started by Guitarst81, Sep 8, 2005.

  1. Guitarst81 macrumors newbie

    Aug 9, 2005
    So the batteries on my wireless bluetooth mouse gave out, so I put in new ones. Although now, for some odd reason, I can use the mouse to click, but when I move it, the cursor doesn't move at all. I've shut off the mouse, and turned it back on. I've even turned my mac off, and switched the mouse on and off and it didn't help either. I also took out the batteries and tried it again. Any clue as to what's wrong?
  2. Michael7k macrumors member

    Sep 9, 2005
    Wiress Mouse

    The identical problem occurred to the wireless mouse that shipped with my Powermac four months ago. Would click on a link yet no movement. With the unit under Apple care I decided to give tech support a call and was so disappointed in the length of call to solve the problem. After 70 minutes on the phone installing current updates and opening the case for a few things he said he would send a new mouse. He next needed a card number for thbe added security of sending the old mouse back. Support was very courtesy, and understandable yet 70 minutes for a wireless mouse?
    Good Luck
  3. Voidness macrumors 6502a


    Aug 2, 2005
    The exact same problem happened to me today. It clicks, but doesn't move at all. Also, before this problem happened, the batteries suddenly died (they where almost full) and now after replacing the batteries it no longer works :(

    Edit: I got it to work again. I don't know if this is the cause of the problem, but I was using NiMH 1.2 volts batteries, that might have caused a problem. Now I'm using normal alkaline batteries, it's working fine. Just be sure to use fully charged batteries, not just half-charged.
  4. rtstovel macrumors newbie

    Nov 26, 2005
    Apple wireless mouse - cursor does't move

    I had the same problem - after a battery change, the cursor wouldn't move, although the bluetooth System Preferences panel showed it was connected, and it would respond to clicks. I tried more battery changes, reboots, and bluetooth device setups to no avail. Sometime later I came back and tried once more, reseating the bateries, and it worked. I have no idea what the problem was.
  5. pmoeser macrumors regular

    Damn Mieces to pieces

    Same here
    After several re boots, batteries in then out, I just took the batteries out and swapped sides and it worked.
    This happens every time I have to change the batteries.
    All bluetooth updates are installed.
    It would be nice to have an answer from Apple
  6. Graeme Pearce macrumors newbie

    Jul 24, 2002
    33 45.255 south, 151 12.910 east

    I also have experienced exactly the same problem several times. My fix is to use a different set of batteries. I''ve had it happen with both regular and rechargeable batteries.

    I thought it was a bit of bad luck. This is sounding like a bit of bad design.
  7. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    It's almost always a problem with having batteries with a low voltage, as Voidness says. :)

Share This Page