Wireless-N Problems.

Discussion in 'MacBook Pro' started by sulhaq, Aug 27, 2008.

  1. sulhaq macrumors regular

    sulhaq

    Joined:
    Jul 29, 2006
    #1
    Hey guys,

    Haven't posted in a while. I seem to be having a problem with my wireless recently. I bought a Linksys WRT160N Wireless router and every time I am connected to Wireless-N and try to download a torrent my wireless drops. I have all the necessary settings set up. I am an advanced Azureus user and have set up all necessary options of limiting peers, peer encryption, port forwarding, static IP etc etc...

    Yet still, every time I start a torrent my wireless drops. The torrent doesn't even start. It barely reaches download speed of maybe 1.5 kbps and the wireless drops. It drops, connects, drops, connects and then drops again. I can't seem to figure out if it's a problem with my wireless card or the router? It's interesting to note that this ONLY happens when I'm connected via Wireless-N, if I change my connection to Wireless-G, all problems go away on their own.

    Any help is greatly appreciated. I am on a 2nd gen macbook pro 2.33 ghz with a WRT160N Linksys wireless-N router with DD-WRT custom firmware on it.

    Thanks.
     
  2. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #2
    Sounds like the router. I had a Linksys router before. Had wireless issues; install DD-WRT mega and it went away for a while and then it started happening again. Got myself a AEBS—problem free!
     
  3. jhamerphoto macrumors regular

    Joined:
    Oct 26, 2007
    #3
    I had similar problems with a D-Link as well. My solution was to buy a Time Capsule, hahaha. Problem free and happy for the past month with my TC :D
     

Share This Page