Wireless Not Connecting on Windows Pro XP via Boot Camp

Discussion in 'Windows, Linux & Others on the Mac' started by Dynasti, Jul 26, 2009.

  1. Dynasti macrumors newbie

    Joined:
    Feb 11, 2009
    #1
    Hello,

    I have recently installed Windows XP with SP2 on my Macbook Pro using Boot Camp. Everything works smoothly enough EXCEPT for the wireless connectivity. There are times when I get full bars, but the system will NOT retrieve a network address for me. I've tried entering one in manually as well as letting the system find one automatically.

    There have also been times when the connection window simply stays stuck on "Waiting for wireless network to be ready."

    I am trying to connect to an 802.11n network through a D-Link DIR 655 wireless router. Using an ethernet cable works fine, the problem only arises when attempting to connect wirelessly.

    I thank you for any assistance you might be able to provide. Just being pointed in the right direction would be a wonderful help; I've been searching around on Google for quite a while.

    Thanks again,
    ~Dynasti
     
  2. oculus42 macrumors 6502

    Joined:
    Dec 9, 2002
    Location:
    Maine
    #2
    Works in Mac OS X?

    You can connect in Mac OS X, I assume?

    It could be an issue with the driver provided by Apple. Have you downloaded the 2.1 Update for Boot Camp? Go to Apple's Boot Camp Support Page and choose the download for Boot Camp 2.1 for Windows XP (on the right). That comes with a number of updated drivers. See if that helps.
     
  3. Dynasti thread starter macrumors newbie

    Joined:
    Feb 11, 2009
    #3
    Yes, it still connects in Mac OSX.

    And, actually, I believe I've already downloaded and installed those updated drivers for XP. I've also installed SP3...so I suppose that must be the case.
     
  4. Dynasti thread starter macrumors newbie

    Joined:
    Feb 11, 2009
    #4
    Anyone have any clue as to what I might be able to do?

    I've tried updating the drivers with several different updates, but that hasn't done anything at all. The wireless card can always SEE my D-Link DIR 655, but it can never connect to it and gets stuck at "Retrieving IP Address". I've tried all the basic things such as setting up a wireless network, a couple of hotfixes, restarting the router, setting a static IP address, et cetera, but nothing seems to work.
     
  5. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #5
    What method of encryption are you using on the router? Try switching from TKIP to AES or vice-versa depending on what is currently in-use. OS X should play well with both.
     
  6. Dynasti thread starter macrumors newbie

    Joined:
    Feb 11, 2009
    #6
    Interesting suggestion... but while I consider myself somewhat capable with computers, I must say I have no idea how to accomplish what you're suggesting or even where to begin. I'll do some research and see if I can get it to work. Thanks for the suggestion!
     

Share This Page