Wireless not working on Windows 7 with the new Mac Mini

Discussion in 'Mac mini' started by fruitpunch36, Jun 28, 2010.

  1. fruitpunch36 macrumors newbie

    Joined:
    Dec 21, 2009
    #1
    Hi. I have the Mid 2010 Mac Mini (yes, it came today) and I just installed Windows 7 RTM on it via boot Camp. I then out in the OS Install disc that came with the Mini and installed all the drivers, then restarted. Everything seems to work except for WiFi. It sees all the networks in the area, but whenever I try to connect to one it says "getting information from (network name)" and then it says "Windows was unable to connect to the network. This is before it even asks for a key. I've tried different encryption types and even tried connecting to an open network and all of them have the same problem. i am able to connect to any network fine on Snow Leopard. Please tell me what I can do!:mad:
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Can you try and power cycle the router and modem?

    Also, if you don't know the encryption key, you won't be able to connect to that wireless network.
     
  3. fruitpunch36 thread starter macrumors newbie

    Joined:
    Dec 21, 2009
    #3
    I know the encryption key, but it doesn't even ask me for it before it fails.

    btw my standard router encryption is WEP (TKIP)

    and I have AT&T U-Verse with a 2WIRE router. Sorry for posting so much

    sorry, typo. I meant WPA (TKIP)
     
  4. BlindSoul macrumors 6502

    Joined:
    May 30, 2010
    Location:
    Israel
    #4
    Try to connect your neighbors network and check if it happens there too. If it's not then it's an issue with your router. Or just try installing the Network driver again...
     
  5. fruitpunch36 thread starter macrumors newbie

    Joined:
    Dec 21, 2009
    #5
    Yes, I've connected to my neighbor's wifi and none of them work. They're all secured. When I disable protection, I'm able to connect to it fine, but when I enable it, same problem. All encryptions work fine, as long as they're unsecured, but I'm not going to leave my router unsecured just because of one computer tho. This is also the only device in the house with wireless n, so i think that might have something to do with it. And sorry about posting so much, im a noob that can't get all his information in a single post XD
     
  6. archipellago macrumors 65816

    Joined:
    Aug 16, 2008
    #6
    are you sure Win 7 supports WEP?

    I think it might be WPA-PSK (etc.) only.

    http://www.neowin.net/forum/topic/868776-windows-7-not-connecting-to-wep-wifi/
     
  7. opeter macrumors 65816

    opeter

    Joined:
    Aug 5, 2007
    Location:
    Slovenia, EU
  8. fruitpunch36 thread starter macrumors newbie

    Joined:
    Dec 21, 2009
    #8
    Ok guys, AT&T solved the issue! Apparently, I'm not supposed to be splitting the feed to the modem. I was splitting it to get cable to my set-top box. I called AT&T yesterday, and the guy on the phone remotely accessed my gateway, and started messing around with settings and then wireless wouldn't work on anything!!! So I had a technician come in today and he gave me a new modem/router. I now have my set-top box hooked up through ethernet, and everything is just perfect :D. Thank you guys!!!
     
  9. mjschranz macrumors newbie

    mjschranz

    Joined:
    Jan 27, 2010
    #9
    Might have been able to fix it with an updated bootcamp. I know I had this issue with Windows 7 on my macbook. Installing only the drivers for bootcamp for windows from the Snow Leopard CD wasn't enough for everything to be working. Once I downloaded bootcamp 3.1 from Apple's support site and installed it, everything was fine.
     

Share This Page