Wireless printer help, is "offline"

Discussion in 'Mac Basics and Help' started by thisisi, Sep 1, 2009.

  1. thisisi macrumors newbie

    Jun 3, 2009
    So the printer that I have is a Canon MP620. Everything was working fine until I installed Snow Leopard, now it wont print wirelessly and it tells me that "printer in offline" when its obviously not.

    Has anyone else had this problem? I don't now how to fix this. :(
  2. jswallac macrumors newbie

    Mar 18, 2008
    I have the exact same problem. I also have a Canon MP620 that I print to wirelessly from mu iMac. I also have a PC connected with a USB cable. The PC with the direct connection still prints without problems, but since installing Snow Leopard tonight the Mac is unable to print. My problem was even worse. The Mac did not even see the printer. I went to Canon's site and downloaded a new driver. Now the Mac sees the printer after I went through the adding printer sequence, but like you it will not print. It reports the printer as offline. I will be calling Apple Care tomorrow. I thought these sort of things were for Windows machines!
  3. jmoney93 macrumors newbie

    Sep 4, 2009
    I spoke with Apple today, they basicly said that I have to wait for Canon to update their Wireless set up assistant. Because that latest wireless network is set for 10.5 not 10.6, that is why the printer offline error keeps happening. So it's a waiting game.....I kind of wish i would have waited to get Snow Leopard and not have to wait to use my printer
  4. jswallac macrumors newbie

    Mar 18, 2008
    There is a solution. You need to go to the canon site and download the new driver for the MP620. That should have been enough, but it is not. You need to go to preferences and delete the printer and then add it back. After this I can now print wirelessly using snow leopard on my iMac over the time capsule network. The Apple guy mentioned that the document he was referencing in TS1253. We did go through some other procedures such as rebooting the time capsule and some manual adjustments, but I believe the key was simply deleting and adding the printer back. It appears the old driver was not over-written by the new downloaded driver. Hope this helps and saves you the hour phone call I just had with Apple to solve this.
  5. thisisi thread starter macrumors newbie

    Jun 3, 2009
    So just download the newest driver and it will work?? OK then. I'll give it a try.
    Thanks for the replies!!

    EDIT: Which driver do I install? the 2 new ones?
  6. jswallac macrumors newbie

    Mar 18, 2008
  7. seamd73 macrumors newbie

    Sep 18, 2009
    Issue fix

    Hi all -

    I had the same issue with my Canon MP480. I recently switched from PC to Mac and was getting a little annoyed until I realized that fixing problems in Mac is a little easier than in PC. My first official fix follows:

    1. After upgrading to SL, I would try to print, and the printer was recognized but "offline". It is connected to my airport and I had previously been able to print wirelessly without any issues.
    2. I downloaded and installed the latest driver from the Canon site
    3. I went to Printer preferences under System Preferences and elected to reset the printing system which deleted my previously installed printer
    4. Then I reinstalled the printer, which was recognized, but this time used the NEW driver (which was called Canon IJ, presumably for "inkjet").
    5. The entire system now works flawlessly just as before.

    Try that. It should work for other Canons as well.

    Good luck!
  8. BVanD macrumors newbie

    Nov 3, 2010
    It works

    Thanks jswallac and seamd73!!!

    I just followed the same procedure as above and it worked for my Canon MP970. There were a few drivers to choose from but something with OS X 10.6 in the title should do you. For my printer it was MP970 series CUPS Printer Driver Ver. (Mac OS X 10.5/10.6).

    This quote from the download site says it all:

    - The printing function when using AirPort connection via USB cable has been modified on the OS side. Therefore, in conformity with this modification this printing function has been enabled on the printer driver side.

  9. fotoguzzi macrumors newbie

    Dec 22, 2010
    mucho thx

    thankyou all for posting, you got my canon back on wireless!
  10. shangeresbased macrumors newbie

    Mar 23, 2011
    printer offline

    my wifi epson printer on mac 10.6.6 was repeatedly 'offline' after a change was made to my wifi router. often the printer would print one time then subsequent attempts to print would not work, with the message saying the printer was offline. (weirdly, the scanner always worked.)
    i several times reloaded the printer driver, tried connecting with a line to the computer or the router and tried to fiddle with settings on the wifi router; always no help.
    then, i reloaded the printer (in print/fax settings of preferences) with help of epson telephone helpline. the technician recommended connecting with the IP tab. i clicked LPD (line printer daemon) and input the IP address from my printer (which was connected thru wifi but unfound). when i input the IP address the driver was immediately found and it loaded. from then on the printer worked fine.
  11. arniepie, Jun 8, 2012
    Last edited: Jun 8, 2012

    arniepie macrumors newbie

    Jun 8, 2012
    this worked for me

    Last week I suddenly began getting the same "printer is offline" error when all had previously been working fine. I tried downloading the latest driver, deleting and re-adding the printer, rebooting the network, reinstalling the Canon software, etc. to no avail. It was becoming puzzling and quite frustrating.

    Glad I found this thread - using the Reset Printing System option in System Prefs resolved the issue. It also worked for my wife's laptop, which had previously been accessing our printer through my desktop via Bonjour. She is now able to print through our wireless network without having to turn my computer on.

    Many thanks to jswallac and seamd73!

    Specs, for the record: Mac Pro 2 x 2.66 GHz, OS 10.5.8 & MacBook Pro 2.4 GHz, OS 10.6.8, Airport Extreme 802.11n (4th Gen) router, Canon Pixma MP495 printer

Share This Page