Wireless Printer Install Error: Not Available from Update Server

Discussion in 'OS X Mountain Lion (10.8)' started by orvn, Oct 24, 2012.

  1. orvn macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #1
    I'm trying to install an Apple-suported (actually Apple-endorsed) HP printer in my office. It's connected to the wi-fi network in question and seems to appear on the "nearby devices" dropdown in my System Preferences.

    When I try to install it, it insists on trying to download "Officejet 4500 G510n-z" software. Then I get an error:

    "Can't install the software for the HP Officejet 4500 G510n-z because it is not currently available from the Software Update server."

    How do I proceed to install my printer?

    I ought to also mention that I'm using a dual-band router (2.4 and 5 GHz). I'm connected to the 5 GHz network (but I believe my router consolidates the networks using different subnet masks or whatever).

    I'm on a mid-2009 MacbookPro running Mac OS X, Mountain Lion 10.8.2 and I have all my updates downloaded (including an HP Printer Update from some time ago).

    Screenshots:
    [​IMG]
     
  2. scottsg57 macrumors newbie

    Joined:
    Oct 26, 2012
    #2
    Same issue, but HP C5280

    I'm seeing the same thing. I've seen other posts that recommend deleting the HP directory in /library/printers and then trying to reinstall the printer. It does cause more software to download, but then I run into the same issue after I've installed the new software. I'm not sure if the Update server is truly down, a broken link, or the OS has the wrong link.

    It seems as the problem has appeared in a recent OS update. I am currently running 10.8.2. I have two Mac mini's and do not have the same issue as my MacBook Pro.

    I hope someone from Apple or HP can help.
     
  3. orvn thread starter macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #3
    Still no resolution and it's happening on multiple MBP's running 10.8.2 now with a completely different BROTHER printer, as well as the HP.

    Only happens wirelessly, been printing via USB cable.
     
  4. orvn thread starter macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #4
    Some of the MBP's are magically printing on the Brother machine wirelessly now, while others aren't (same software update server error).

    Same error with the HP printer on all machines. *sigh*
     
  5. Jeff Malone macrumors newbie

    Joined:
    Jan 8, 2013
    #5
    I was having this problem with an older model (pre Gatekeeper) Brother 2270DW.

    To resolve my problem I set Gatekeeper to "Anywhere" in System Preferences ->Security and Privacy -> Allow applications downloaded from anywhere -> reboot (mine actually required a reboot)

    I changed it back to the default Mac App Store and identified developers and rebooted again after the printer installed.
     
  6. ldcook87 macrumors newbie

    Joined:
    Jul 24, 2013
    #6
    fix

    Hey everyone

    Sorry if this is a little lengthy but I want to make sure I don't miss anything

    Not sure if people are still experiencing this problem, I recently had the same issue with my wireless printer. (**side note rant** I called Apple for some help and to shed a little light on the situation, the guy at Apple was totally useless, gave me a number for brother printers that didn't work and did not want to try and trouble shoot the situation without opening a $60 case file. Very disappointed with Apples customer service **rant over**)

    Here's the fix

    Please make sure both printer and Mac are connected to the same network and proceed.

    Locate all the printer drivers available on your Mac, to do that:

    Open Finder
    in the menu bar select - Go > Computer > Mac HD > Library > Printers > PPDs > Contents > Resources

    Now you should see a list of printer drives (I have a brother and HP printer installed on my Mac so I only have Brother and HP drivers).

    Once you have confirmed that your printer is listed you can move to the next step (if it is not listed try downloading the driver from apple - Google > apple printer drivers "insert printer brand" you should get a link similar to this http://support.apple.com/kb/dl894)

    Now

    System Prefs > Print/Scan > + > select "Add printer or scanner"
    ** note ** don't select the your printer model if it's listed in the drop-down box. (use screenshot 1 from the first post as a reference)

    A box should appear that says Add on the top and has 4 options (default/fax/IP/Windows)

    Leave it on default and select your printer from this list.

    You will see a heading named "Use" (it's the 3rd one down)

    From the "Use" drop-down menu select "other"

    Now use that path from above that you used to find the printer driver and select your printer CUPS file

    *** Go > Computer > Mac HD > Library > Printers > PPDs > Contents > Resources ***

    When you click "open" you should see your "printer model + CUPS" in the "Use" heading.

    Now select Add and your printer will go through the install process and you should be done.

    Hope this helps
     

    Attached Files:

  7. Compile 'em all macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
    #7


    Sorry to bump this super old thread but just wanted to thank you for this. I too was also getting the same error about failing to download the software (BROTHER DCP -7070DW) and I followed your instruction and it worked! so Thanks again!
     

Share This Page