Wireless Printing: ASUS RT-N66U and MBA OSX 10.8

Discussion in 'OS X Mountain Lion (10.8)' started by Ohlias, Apr 29, 2013.

  1. Ohlias macrumors member

    Sep 28, 2011

    I've been trying for days and have done extensive research, but cannot get this to work:

    The ASUS router is the hub of my home network. My Windows 7 desktop is hardwired to it and the MBA is usually connect via Wifi. An HP DeskJet F335 AIO is also connected to the router via USB. The Windows PC is able to access and print using the printer without issues. The MBA on the other hand, is unable to communicate with the printer. I have tried connecting the MBA using Wifi and ethernet to no avail. The printer software is on the Mac and when the printer is hardwired via USB to the MBA, it prints without fail.

    I've tried fooling with many different settings in both the router and the MBA without any success. Here are the instructions I used from ASUS: http://support.asus.com/Search/KDetail.aspx?SLanguage=en&no=709CD7A4-CFFE-D939-717D-D7CFD82C44B1&t=2

    Can anyone help!? I'm losing my mind...

    BTW, the MBA sees the internet and the USB hardrive that is connected to the SECOND USB port on the router...


    Thank you so much!
  2. hedenberg macrumors newbie

    Apr 27, 2014
    Hi Ohlias,

    I have the exact same problem. Did you solve it?

  3. JuGillespie, Aug 26, 2014
    Last edited: Aug 26, 2014

    JuGillespie macrumors newbie

    Aug 26, 2014
    Solution Found

    I struggled to set up an old Laserjet 6p Printer with RT-AC66u.

    The solution was as seen below. Ensure for Queue you type it as seen below. The IP is universal.

    1) Go to printers
    2) Press '+'
    3) Select IP
    4) Enter info as below

    Protocol: LPD
    Queue: LPRServer

    Name: *I just left as it was, the address. You could probably change it if you wish*
    Location: *Again can probably set as you like, i left it blank*
    Use: *Select your printer driver. I had to manually select the gutenprint version of the driver for my print for it to work as Post Script version would not work.*

    Here is the original location of support website - http://support.asus.com/Search/KDetail.aspx?SLanguage=en&no=709CD7A4-CFFE-D939-717D-D7CFD82C44B1&t=2

    Good luck
  4. 6th macrumors newbie

    Feb 29, 2008
    Old post, but thanks for this! all the links on the Asus support site are down

Share This Page

3 April 29, 2013