Wireless Printing

Discussion in 'Mac Basics and Help' started by AirborneAngel, Jul 23, 2008.

  1. AirborneAngel macrumors 6502

    Joined:
    Sep 8, 2007
    Location:
    Los Angeles, CA
    #1
    Alright, I was wondering if there is any way that I can print from my MacBook (with wireless) to a non wireless printer connected to a desktop connected to the internet. Is there any way that I can have my Mac print to my desktop's IP?

    Cheers
     
  2. atlanticza macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #2
    Is it a network-capable printer? Do you have a wireless router? And is the desktop a PC or Mac?
     
  3. AirborneAngel thread starter macrumors 6502

    Joined:
    Sep 8, 2007
    Location:
    Los Angeles, CA
    #3
    Sorry, the printer is not network compatible (but it is hooked up to a PC that is connected to the internet.) I do have a wireless router, its what the MacBook runs off, and the PC is connected to it via a ethernet cable.
     
  4. atlanticza macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #4
  5. AirborneAngel thread starter macrumors 6502

    Joined:
    Sep 8, 2007
    Location:
    Los Angeles, CA
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    It's built in to Mac OS X. Here is more info.
     
  7. AirborneAngel thread starter macrumors 6502

    Joined:
    Sep 8, 2007
    Location:
    Los Angeles, CA
    #7
    Alright, so I downloaded Bonjor for my PC (which is not wireless) but it says "No Bonjour Printers are Available." What do I do?
     
  8. AirborneAngel thread starter macrumors 6502

    Joined:
    Sep 8, 2007
    Location:
    Los Angeles, CA
  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    Did you read this? It might be helpful. Also, I understand Bonjour doesn't detect directly connected printers... only wireless.
     
  10. mwchris macrumors regular

    Joined:
    Apr 12, 2008
    Location:
    Kentucky
    #10
    You do not need any special software as long as the printer you are printing to has mac drivers. Do the following and it should work. Note there may be some tweaking of my directions depending on your specific setup. Since I do not know what version of OSX you are running there is one instance that will be different. I will mentioned that below.

    1. On your Mac - Install the print drivers for the printer you are going to use.

    2. On PC - Navigate to your printers list. Left click on the printer you wish to print to. Then Right click on the printer and select sharing. A window will open that displays the sharing information. Most likely you will have to run the "Network Wizard" to enable printing, assuming you have never networked the PC. If it has already been networked, just selected enable printer sharing. When you run the network wizard be sure you do the following things: Remember the name you assign the computer, choose MSHome for workgroup name, and at the end turn on print and file sharing. At the end of the wizard select finish do not make a disk or set up other computers. Then restart.

    3. On your Mac -
    3.1 If running OSX 10.5 do the following: Go to system preferences and select printers. Click the "+" sign to add a new printer. In the window that opens up select the "Windows" tab. Then "MSHOME" should show up at the bottom, navigate through to the name of the computer I told you to remember. Select the computer and a list of available printers should come up. It may ask for a user name and password, you should be ok to just click OK, but be sure you also click "remember in keychain" or else printing may require a password every time or just not work. Choose the printer and then in the bottom of the window navigate to the drivers that you installed previously then click add.

    3.2 - Mac OSX 10.4 - On my mac running 10.4 originally I had to do something different than what I am going to tell you, but if you have 10.4 and what I tell you doesn't work, let me know and I can most likely tell you the work around. Open system preferences and choose print & fax. Click the "+" for add printer. Be sure "Default" is highlighted at the top of the window that opens. Then at the bottom select "more printers". Another window will pop-up and select "Windows Networking". From here hopefully it will say "MSHOME" below (If not let me know), then navigate to the PC you are using, and then to the printer. You may be asked for a user and password. You should be ok just clicking yes, but be sure to also click save in keychain, or you may have problems later. (If the password is wrong it won't let you select the printer). Next add the drivers from the list at the bottom and click add.

    4. That should do it. Open a document, webpage, etc. and print a test page. If it spools but doesn't print there may be password issues or wrong driver, like I said it depends on your particular system.

    Let me know if you have any questions.
     
  11. atlanticza macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #11
    Just remember that you'll have to switch on your PC to use the printer from your Mac though ;-)
     
  12. AirborneAngel thread starter macrumors 6502

    Joined:
    Sep 8, 2007
    Location:
    Los Angeles, CA
    #12
    Hmm...that doesn't seem to be working. I installed the drivers for my Canon Pixma Inkjet MP780 and set up networking on my PC, but the printer isn't showing up.

    PS I'm running Leopard 10.5, no printers are showing up under the windows tab.
     
  13. mwchris macrumors regular

    Joined:
    Apr 12, 2008
    Location:
    Kentucky
    #13
    Well, answer this first, when you go to add a new printer on the mac under the windows tab does the name of the computer that the printer is connected to show up?



    Also, when you set up the network using the wizard did you turn on printer and file sharing? If so when you open up the finder on the Mac if the windows computer is turned on, awake, and configured correctly it's name should show up under the "shared" directory. So, if you can't see it there, you need to run your network wizard again.

    Answer those two things and I will try and help you.

    Chris
     
  14. AirborneAngel thread starter macrumors 6502

    Joined:
    Sep 8, 2007
    Location:
    Los Angeles, CA
    #14
    Thanks man, I got it to work. You have no idea how much I appreciate you guys taking the time to help me out!

    Cheers!
     

Share This Page