Wireless Questions

Discussion in 'Mac Basics and Help' started by Mr-F, May 15, 2005.

  1. Mr-F macrumors newbie

    Apr 27, 2005

    I've just purchased my first ever Mac and am really using it in comparison to my old intel PC. However, I am having trouble setting up my wireless connection. I was wondering if someone could give me some help on this matter.

    Basically, I've got an old 802.11b wireless router which I was told my powerbook would work with. I know that the wireless connection works since I've been using it for the past year or so with my old laptop. However, I can't seem to connect to it using my new Mac. What am I doing wrong? The mac seems to see the wireless network and connects to it using the WEP key. Yet its not picking up the DHCP server and thus assigning its out IP address which obviously doesn't work. Any ideas?

    I have even mad a entry in the DHCP server for the mac address of my wireless card as well as a small pool of free ip address which can be assigned to any new connections. Yet it still doesn't seem to want to work for me.

    Thanks in advance for any help you can give me on this.

  2. Applespider macrumors G4


    Jan 20, 2004
    looking through rose-tinted spectacles...
    Congrats on your first Mac. Sorry that you're having problems.

    I'm assuming that you've got the obvious 'using DHCP' checked in System Preferences/Network - highlight Airport, go to Configure and check under TCP/IP rather than using 'Manual DHCP or something else'

    Next thing is a small workaround since Tiger still has a few bugs. There have been a few reports of people's wireless dropping out after getting Tiger. The problem seems to be that their computer's name is too long for certain routers to assign a DHCP to. If you go to System Preferences, Sharing and click on Internet, it will tell you what your computer's name is. If it's more than 20 characters (the default is firstname surname's Computer) so it might be, try shortening it so that it's less than 20 and see if it then works with the router.
  3. Mr-F thread starter macrumors newbie

    Apr 27, 2005
    Thanks for your reply Applespider. However, none of them help. I had already found the threads about the computer name and checked that. It was longer, but even after I set it to a short name it still doesn't work. Also the airport options are set correctly. So there must be something else wrong. Any other ideas? Its just strange since everything else has just worked, as it is meant to do, apart from the wireless stuff.

  4. oriol macrumors member


    Jan 5, 2005
    right behind ya!
    i got the same problem when i got my babe powerbook (12" :p ). what worked for me has to put a dollar sign ($) in from of the WEP key.

    try it if it doesn't work contact ur ISP. ;)

    my 2 cents
  5. ghostee macrumors 6502

    Feb 25, 2004
    Villa Park, IL
    I was having the same problem. I had a pool with enough IPs to cover the iBook I was connecting, but the IP was always a 169 auto-assigned by OSX one. I increased the pool of DHCP assignable IP's on the router (Linksys WRT54G) by a few, and was able to connect. Strange, but it worked.

Share This Page