Wireless Router

Discussion in 'MacBook Pro' started by johnpc, Sep 11, 2010.

  1. johnpc macrumors member

    Joined:
    Jul 15, 2010
    #1
    My roommate and I both have 13.3 inch macbook pros and we recently acquired a Belkin wireless router from a friend. When plugged in the network becomes available but both of our computers show an ! in the airport item in the menubar. The internet worked for about 20 minutes after installation then failed. We restarted the router and it worked again for maybe five minutes, and now we can't get it working at all. Bad router do you think or can the settings be changed in any way to make it work correctly?

    Thanks
     
  2. RaceTripper macrumors 68030

    Joined:
    May 29, 2007
    #2
    The ! typically means you are connected but failed to obtain an IP address from the router, preventing you from using the network. That could mean the router is using MAC (Media Access Control) address filtering, in which case you either need to turn filtering off, or you need to add the MAC addresses of your MBPs airport cards (every network interface has such an address). If not, then something else in the router's setup is preventing your MBPs from getting an IP address.
     
  3. johnpc thread starter macrumors member

    Joined:
    Jul 15, 2010
    #3
    So any tips on how to tinker with the router settings?
     
  4. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #4
    get a new router. my belkin networking products never worked right.
     
  5. johnpc thread starter macrumors member

    Joined:
    Jul 15, 2010
    #5
    Don't know if I'll be able to get a new one. I'm a poor college student :(. But anyone know how to access the settings of this router? it's got a button on it that says WPS on it.
     
  6. racedude macrumors member

    Joined:
    Aug 28, 2010
    Location:
    Carmel, IN
    #6
    Assuming you can't connect to it at all, plug your laptop into the router using an Ethernet cable, and connect to the control panel. To do this, enter in the IP address of the router (normally 192.168.1.1 or 192.168.0.1) and sign in. I'd lookup the model of your router for more detailed information such as the default login and password to sign in. From their, you can access the controls of the router, such as turning off MAC filtering.
     
  7. sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #7
    Several years ago Belkin routers had a reputation for overheating and crashing under heavy use. So if your twenty minutes of usage included lots of streaming video or torrent downloads, that might be your problem.

    It's hard to understand how you could have a ! and still be able to access the Internet, though.
     
  8. johnpc thread starter macrumors member

    Joined:
    Jul 15, 2010
    #8
    For a while I didn't have a ! it was only after like 20mins that the ! arrived. During the 20 mins there was light surfing of stumbleupon/facebook nothing too heavy. Then it randomly cut out.
     
  9. sdsvtdriver macrumors 65816

    Joined:
    Jul 31, 2008
    Location:
    Southern California
  10. johnpc thread starter macrumors member

    Joined:
    Jul 15, 2010
    #10
    Thanks sdsvtdriver. Kinda made me feel thick for not thinking to try that first but it worked like a charm. Sending this response sans Ethernet cable. Thanks!
     
  11. BigBeast macrumors 6502a

    Joined:
    Mar 6, 2009
    #11
    Um...

    I'm pretty sure that if MAC address filtering was already enabled, they wouldn't be able to log onto the wireless network in the first place. Just sayin...:rolleyes:
     
  12. crypticlineage macrumors regular

    Joined:
    Jun 24, 2010
    #12
    Belkin makes some of the worst networking products. Plus I happen to have an opinion that most router softwares are not so good at all.

    DD-WRT gives a much better performance on supported routers than any of the proprietory software that came with router.

    OP: you posted success using wired, but have you checked wifi again?
     

Share This Page