"witchdaemon" would like to control this computer using accessibility features

Discussion in 'Mac Basics and Help' started by bodhisoma, Nov 11, 2013.

  1. bodhisoma macrumors newbie

    Joined:
    Nov 10, 2009
    #1
    I'm using Witch, a window-switching app, and since upgrading to Mavericks I'm getting this error message:

    "witchdaemon" would like to control this computer using accessibility features

    Went into Security & Privacy > Privacy and checked off witchdaemon. Hotkey did nothing.

    Went into the WitchDaemon pref pane and enabled it but same as before, when I try to activate it (via hotkey), I continue to get the error message.

    I've manually killed the witchdaemon process, returned to the witchdaemon prefs, re-enabled it which does restart the process but trying to use it by hitting the hotkey just results in the same error message.

    Anyone else running into this issue or know of a solution?

    Thanks much in advance.
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    It probably wasn't ready for Mavericks. You may would want to contact the developers and see if they will be updating the software and uninstall the current version.
     
  3. bodhisoma thread starter macrumors newbie

    Joined:
    Nov 10, 2009
    #3
    That doesn't make sense, though I appreciate the reply.

    Witch is trying to control windows, OS X is complaining the app doesn't have permissions when it really does. That's an OS fault.

    If, on the other hand, Witch tried to control windows, OS X complained about it not having permissions, permissions were then set correctly, OS X no longer complained but Witch did nothing, that would point to an application problem.

    I've never had a bad thing to say about OS X but they've really ****** the pooch with Mavericks. Ripped out Java without warning, can't get Wine to work, computer significantly slower than before.

    Given the events of the last few years, a harbinger, I'm afraid... :(
     
  4. hopper8 macrumors newbie

    Joined:
    Jun 5, 2011
    #4
    Having the same problem - any solution?

    I'm having the same problem. Bodhisoma or any other: have you come up with a solution? Of Witch app still not working with OS X Maverick?

    Thanks,

    Hopper
     

Share This Page