Woke up to iMac screen looking garbled

Discussion in 'iMac' started by namethisfile, Apr 13, 2009.

  1. namethisfile macrumors 6502a

    namethisfile

    Joined:
    Jan 17, 2008
    #1
    I thought my iMac died this morning since it looked like this:

    [​IMG]

    [​IMG]

    But, i was able to shut it down by pressing the power button and restart it. thankfully, the screen fixed itself and the computer went back to normal.

    earlier in the day, my screen got garbled after i accidentally switch resolutions of the monitor but fixed itself without restarting.

    i don't know what is wrong with it. is my imac dying? is this a software issue or a hardware one? this is the first time i have encountered this "pixel garbage" as i've read it on the internet.

    my imac is a late 2007 model by the way with the ati 2600 hd pro card running leopard 10.5.6 and has the latest updates and whatnot.
     
  2. Tomorrow macrumors 604

    Tomorrow

    Joined:
    Mar 2, 2008
    Location:
    Always a day away
    #2
    If it only happened this one time, and correcting the screen resolution (and leaving it alone for a while!) fixed the problem, then I wouldn't worry about it.

    If it's a persistent problem, I'd look into either the logic board or video adapter.
     
  3. mcavjame macrumors 65816

    mcavjame

    Joined:
    Mar 10, 2008
    Location:
    phased to this universe
    #3
    I never had this issue before, but when I upgraded my Macbook to the machine with the 9400 GPU, I notice that it often displays a similar screen after a long sleep or disconnecting from a data projector/second monitor.
     
  4. namethisfile thread starter macrumors 6502a

    namethisfile

    Joined:
    Jan 17, 2008
    #4
    Ugh! thanks guys for responding. it's reassuring to know that i am not the only one w/ this problem. and, i hope it isn't anything serious and/or costly since i decided not to get applecare before the regular 1 yr apple warranty expired.

    i had a 2nd extended display connected to the iMac just recently before I decided not to use it due to other problems not related to video at all. it never had this glitch unplugging or plugging the 2nd display when i was using it though. and, it never had this problem waking up from sleep or hibernation. so, it is baffling to me that it would just decided to show up after 1 year and 5 months of owning this computer.

    it does have other problems like the Login window and UI something or other processes in activity monitor showing "Not responding." i don't know if they're inter-related or isolated problems. but, my computer is ok for the most part. i can use it at extended amounts of time. i only notice that the computer freezes in the morning (for the most part), when i wake up. before this video problem, my computer would be unresponsive forcing me to shut it down and restart. this is when i decided not to use my 2nd display just to see if it was the cause.

    i checked the hdd drive w/ disk utility and everything seems to be ok.

    anyway, there is really nothing i can do about all of these ills since i am not doing anything abnormal to it. i just hope there is a fix to it.
     

Share This Page