Wolfenstein ET problems

Discussion in 'Mac and PC Games' started by rossag, Nov 29, 2007.

  1. rossag macrumors newbie

    Joined:
    Nov 29, 2007
    #1
    Got a bit of a weird one here. I've downloaded every conceivable version of this game and currently have what I believe to be the latest universal version (2.60d).

    I can download and open the file without any problems, and am able to move the folder to my games folder in applications. The problem is I can't even start it. If I try to launch the game, it will bounce, I'll get the games console up and it'll load stuff then disappear and if I have the sound up, I'll just get a constant 'popping' noise (like when a pop up tells you you're low on battery). This will just carry on until I force quit it.

    I've tried everything and I have no idea what it is. Does anyone know about this problem?

    Cheers

    Ross
     
  2. rossag thread starter macrumors newbie

    Joined:
    Nov 29, 2007
    #2
    My specs

    Forgot to mention my specs:

    Blackbook 2.2
    4GB of RAM
    Leopard 10.5.1
     
  3. rossag thread starter macrumors newbie

    Joined:
    Nov 29, 2007
    #3
  4. denisvj macrumors regular

    denisvj

    Joined:
    Sep 9, 2006
    #4
    Did you try to repair permissions ?

    I had the same problem and repairing permissions solved it also left click over the folder and select "get info" and see if you can read/write to the folder.

    Good luck .

    :)
     
  5. applekid macrumors 68020

    Joined:
    Jul 3, 2003
    #5
    Try deleting the preferences. I kind of remember having trouble with ET. At least I remember getting to the main menu though.
     
  6. rossag thread starter macrumors newbie

    Joined:
    Nov 29, 2007
    #6
    Repair permissions

    I tried repairing permissions but it didn't seem to work. I keep getting these two 'errors' on repair disk though:
    – Permissions differ on "System/Library/PrivateFrameworks/GraphicsAppSupport.framework/Versions/A/Frameworks/QuartzComposer.framework", should be lrwxr-xr-x , they are drwxr-xr-x .
    – Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.

    Any idea what that's about?

    I took a look inside the Wolfenstein ET folder in my Application Support folder and it was empty? Surely it's meant to have something in? I am thinking that maybe I need to copy someone elses folder in there for it to work?

    Thanks for your help
     
  7. afaak macrumors newbie

    Joined:
    Dec 6, 2007
    #7
  8. WildPalms macrumors 6502a

    WildPalms

    Joined:
    Jan 4, 2006
    Location:
    Honolulu, HI
    #8
  9. WildPalms macrumors 6502a

    WildPalms

    Joined:
    Jan 4, 2006
    Location:
    Honolulu, HI
    #9
    Game is crashing on OpenGL (graphics) requests. Curiously, on Carbon....
     
  10. WildPalms macrumors 6502a

    WildPalms

    Joined:
    Jan 4, 2006
    Location:
    Honolulu, HI
    #10
    rossag, can you try this please:

    Locate the Wolfenstein ET icon and Control+Click (or right click) and select Get Info. (alternatively click on the icon once and press Apple + I)

    Under the general section, check the "Open using Rosetta"

    Now try to run the game. Let me know if this works.
     
  11. supericarus2 macrumors newbie

    Joined:
    Jan 1, 2008
    #11
    Hi all,

    Same problem here with wolfenstein 2.60d and macbook santarosa (2.2 GHz) with leopard. I have tried following the hint and forcing to open with rosetta but the crash (producing a sound) continues to occur. Any other suggestion?

    supericarus
     
  12. captainyesterda macrumors newbie

    Joined:
    Jan 1, 2008
    #12
    Yay I'm glad to see other people with the same problem- I had no idea where to look for help! I've got the same issue as Ross and no clue what to do. I'll keep working on a solution and hopefully one of us will figure something out. Btw Happy New Year all!

    Tom
     
  13. afaak macrumors newbie

    Joined:
    Dec 6, 2007
    #13
    If we all have SR macbook the problem might be in graphics card (drivers):confused:
     

Share This Page