Wonky iBook.

Discussion in 'PowerPC Macs' started by windywoo, Jun 24, 2009.

  1. windywoo macrumors 6502a


    May 24, 2009
    I let the charge run out of my G4 iBook the other day to recalibrate the battery but when I tried to turn it on again it wouldn't respond, with or without the charger plugged in. When I took the battery out it would turn on but just blasted the fans.

    I completely recharged the battery and it still gave me the blasting fans. I took it apart, made sure all the cables were tight and it still wouldn't boot. From time to time it would give me chimes, give me a grey apple and then a black screen (backlit).

    Then, after reading some google results I applied pressure on the case and tried it at various angles. Oddly, it came on when I tilted it, and thereafter would power up without tilting. However, it went into sleep mode earlier and wouldn't come out until I powered it off and on again.

    To add further mystery, when I manually put it into sleep it works fine, from Apple menu or lid closing.

    Google suggests a faulty logic board, but those posts all mentioned that the machines stopped working altogether. Mine is working but messing with my head. Is it a logic board on its way out or a connection I have missed when I took it apart?

  2. cMacSW macrumors regular

    Mar 20, 2006
  3. philipt42 macrumors 6502


    Jun 26, 2009
    Probably logic board...

    ...but i fixed mine by soldering the gpu, which is the chip under the hard drive cord. a helpful site...URL="http://coreyarnold.org/ibook"]http://coreyarnold.org/ibook[/URL]

    btw, that was today. and i did it w/a screwdriver and the stove burner!

    Attached Files:

Share This Page