Won't boot after changed permissions on startup drive

Discussion in 'Mac OS X Lion (10.7)' started by ftnpro, Apr 17, 2012.

  1. ftnpro macrumors newbie

    Joined:
    Oct 11, 2009
    #1
    Hi there. I have a new MacBook Air running Lion. Every time I use my backup software, it changes the permissions on my external drives, and I have to change them from read only to read & write, so I've gotten into that habit.*At one point, I noticed that the permissions on my internal *startup disc* were read only, so I (foolishly, I now know) changed the permissions on the startup disc to read & write, with apply to all enclosed items checked. As I continued working, I got messages that a number of extensions could not be used and will be disabled (or something like that). I decided to reboot, so the computer could reset and hopefully correct things.

    When I tried to boot, it hung up on the grey screen with the Apple logo and the spinning clock/gear. I let it spin for a while, then forced power down and tried to boot in safe mode. The progress bar appeared as it's supposed to, but when the progress bar finished, it went back to the grey screen and hung up again. I let it spin for over 40 minutes before powering down, just in case it was doing diagnostics or something.

    I am traveling in Nepal, so I don't have access to the original OS DVD (nor do I have an optical drive to put it in). And I'm so very far from an Apple Store. Any suggestions for getting the computer to boot, at least in safe mode?

    Thanks for your help!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    What backup software are you using? It shouldn't be changing permissions. I recommend Carbon Copy Cloner for backups.
    This may be helpful: Mac OS X: Gray screen appears during startup
    OS X Lion: About Lion Recovery
    Apple - OS X Lion Recovery - Introducing Lion Recovery
     
  3. ftnpro thread starter macrumors newbie

    Joined:
    Oct 11, 2009
    #3
    Yup, I'm using Carbon Copy Cloner, and it changes the permissions each time I clone some key folders to my external drives. But I don't necessarily think it had anything to do with the startup disk permissions... I was just in "fix permissions" mode.
     
  4. ftnpro thread starter macrumors newbie

    Joined:
    Oct 11, 2009
    #4
    I'm pleased to report that someone over on the Apple forums solved my problem:

    Boot from your recovery partition (command-R at startup), launch Disk Utility, and run Repair Permissions on the startup volume.

    So, now that I've stopped sweating bullets, any ideas why Carbon Copy Cloner changes the external drive permissions every time? My workflow: I have CCC set to backup my video clips and photos each night. When it does, it changes permissions of the external drives to Read Only. During the day, I edit with that media, so I have to go change the permissions to Read & Write, so I can save new files, render to that external drive, etc.

    Not a huge hassle, just an annoyance that I'd like to be able to address. Thanks!
     
  5. bombich macrumors newbie

    Joined:
    Dec 15, 2011
    #5
    CCC applies the permissions and ownership from the source to the destination. If the root of your source is your startup disk, then the root of your destination will match those of the startup disk. As of Lion, those are very restrictive: owner root, read-only.

    If you're trying to copy just a single folder, choose "Choose a folder" from CCC's Source menu to choose that specific folder. Then do the same in the Destination menu, choosing the corresponding folder on the destination. When you choose a specific folder as the source, CCC only considers those items for the backup. If you choose a folder that you own as the source, then the destination folder's ownership will be set to your account and you can avoid this privileges problem.

    Mike
     
  6. ImJillyBean macrumors newbie

    Joined:
    Aug 18, 2014
    #6
    Tried disk repair, still not rebooting

    First off, I'm glad to see I'm not the only person who has done this and has this problem!
    So I pressed command R when starting my computer, repaired disk permissions (which took forever), and restarted my computer. It's still not booting :(
    Any suggestions?
     

Share This Page