Won't Boot Past Grey Screen - No Logo - Recent SSD Upgrade

Discussion in 'MacBook Pro' started by bluearctop, Jul 15, 2011.

  1. bluearctop macrumors newbie

    Joined:
    Jul 15, 2011
    #1
    Hi - about a month ago in my Macbook Pro 2010 I had my main HD changed to a SSD and my optical drive removed for the original HD. All was well. This morning I opened the lid and the desktop was locked up. Did a hard reboot, and now I can't get past the grey screen. I've tried everything I can think of:
    Reset PRAM - (this actually got me a little further as originally I couldn't even get to the startup chime)

    Hook Up External Monitor - never fires on

    Hooked Up USB Hard Drive (which I used to be able to boot off) - not detected

    Hooked up Optical Drive via USB w/ installation disks - not detected.

    Holding down "option" when booting doesn't give me any menu.

    What do you think the problem is? I have Apple Care, but I'm not sure if they would service it since it's been modified?

    Thanks in advance.
     
  2. Brammy macrumors 65816

    Joined:
    Sep 17, 2008
    #2
    Did you try reseating the SSD and replacing the optical drive?
     
  3. bluearctop thread starter macrumors newbie

    Joined:
    Jul 15, 2011
    #3
    Not yet, was hoping I wouldn't have to dig it apart. If it was a bad SSD, wouldn't I still be able to boot off an external drive? Once the boot chime goes off, I don't even get the spinning icon that you normally see when booting. Does that indicate anything?
     
  4. Brammy macrumors 65816

    Joined:
    Sep 17, 2008
    #4
    I don't know, honestly, unless there is something physically wrong with the connector causing a system fault someplace.

    I hear ya on ripping it apart, but the next step is to see the fine folks at the Genius bar so you're going to have to at least put the optical drive back in.
     
  5. bluearctop thread starter macrumors newbie

    Joined:
    Jul 15, 2011
    #5
    Yeah, that was my next question :) What will they do if they see my modified Macbook - will they tell me it voids my Applecare? So I need to rebuild it to stock setup?
     
  6. Brammy macrumors 65816

    Joined:
    Sep 17, 2008
    #6
    The SSD swap won't void it, but the optibay will.
     
  7. bluearctop thread starter macrumors newbie

    Joined:
    Jul 15, 2011
    #7
    Thanks for your advice. I guess it's time to call up my technician. Ugh.
     
  8. satchow macrumors 6502

    Joined:
    Jul 11, 2011
    #8
    Just put the optical drive back in before taking it to the Genius Bar. First time I brought it in, I still had a 2nd HDD in there. The guy troubleshooted and said he couldn't do anything else unless I replaced the drive. The next time I came in, I overheard the guy next to me and he got a replacement iPod Touch after his currently jailbroken one broke. They're usually really nice about stuff and try to help you out if you're nice to them.

     
  9. Brammy macrumors 65816

    Joined:
    Sep 17, 2008
    #9
    Follow up with what the issue was. I'm very curious.
     
  10. bluearctop thread starter macrumors newbie

    Joined:
    Jul 15, 2011
    #10
    OK, so I put back in the optibay and left the SSD. Brought it to Apple. They took the SSD out, and were able to Net boot it w/o any hard drive. They tested the SSD and it wouldn't boot. So problem is a faulty OCZ Vertex 2. Bummer. It was only about a month old. So now have the original setup back w/ the old HD and Optical, and waiting on the RMA for the Vertex and will give it another shot.
     
  11. Philflow macrumors 65816

    Joined:
    May 7, 2008
    #11
    I was just going to say, is this a Vertex 2? So it is.

    Vertex 2, and all other Sandforce drives, are plagued with reliability problems. As you can read here.
     
  12. mgkz macrumors newbie

    Joined:
    Oct 4, 2011
    #12
    Exact same problem

    Four months ago I replaced the SuperDrive in my mid-2010 MBP with an OCZ Vertex 2 and kept the original drive in place (used as a Data disk for files, no OS or Apps on it).

    It was very fast and made a huge difference in daily use, but this morning I think it just died without any warning.

    I get a chime on startup and go up to a grey screen, but never get to the Apple logo. It stays there forever and switches off instantly if I hit the power button.

    I tried:

    - resetting PRAM a few times (resetting works as I hear the chimes and restart)
    - plugging an external DVD drive with the Snow Leopard DVD that came with the machine (ignored by the MBP)
    - Shift, Alt, Cmd + S and other keyboard shortcuts have no effect
    - removing the 2 RAM sticks and switching their positions
    - letting the battery empty, waiting a few hours and rebooting
    - booting from SD card with Lion (clone of Lion Installer) from SD card slot

    I always end up on the grey screen of death.
    I don't get any option to boot from the Lion recovery partition (also on the SSD), which seems to confirm that the SSD is dead.

    The likely culprit is the OCZ Vertex 2 SSD drive which must have died.

    It was working just fine the day before, I switched the machine off normally.

    Next step: removing the SSD to see if this allows booting from the DVD.

    15" MacBook Pro 2010 i7 2.66GHz
    8GB RAM
    500GB HD
    240GB SSD (OCZ Vertex 2) in place of SuperDrive
    OS X Lion 10.7.1
     
  13. mgkz macrumors newbie

    Joined:
    Oct 4, 2011
    #13
    Confirmed: OCZ Vertex 2 Dead

    I had to unplug the SSD from the OptiBay to be able to restart from a Snow Leopard DVD on an external DVD drive, or from the Lion Install on an SD card.

    Currently restoring all files to a standard HD in the OptiBay, thanks to TimeMachine.

    Not sure I'll trust a replacement SSD drive from OCZ as the great gains in speed are nothing compared to reliability.

    Indeed, forums are full of horror stories with OCZ Vertex 2 http://www.newegg.com/Product/Product.aspx?Item=20-227-551
     
  14. Gurutech macrumors 6502

    Joined:
    Jan 22, 2006
    #14
    OCZ , and any SSD using the Sandforce controller have stability issues.
    It's really fast, and random 4k read and write is faster than Intel and Samsung, but if stability is your primary concern, you gotta buy Intel or Samsung's SSD.
    If i were you, I would return the SSD, and buy from Samsung.
     

Share This Page