Won't connect to wifi

Discussion in 'iPhone Tips, Help and Troubleshooting' started by TheBusDriver, Jun 29, 2007.

  1. TheBusDriver macrumors 6502

    Dec 24, 2005
    My iPhone won't connect to my encrypted Wifi it will connect to my neighbors unprotected wifi but not mine I put in the pass word and still no dice, also tried putting a $ in front of it but still no good any help appreciated I called apple and they haven't been of help.

    Thanks Steve
  2. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    EDIT: okay, I won't be mean... Please provide more details, so we can help you. What router do you use? What encryption standard? Do you use MAC filtering? What error do you get when you try to join?
  3. TheBusDriver thread starter macrumors 6502

    Dec 24, 2005
    actiontec router, I don't know the encryption standard and I don't know about MAC filtering. It says unable to join network
  4. skubish macrumors 68030


    Feb 2, 2005
    Ann Arbor, Michigan
    Well if you expect help you need to figure those out.
    Go to the router settings and find out what encryption you are running.

    You may want to turn off encryption temporary first to confirm you can connect to the router.
  5. rdrr macrumors 6502a


    Nov 20, 2003
    Just a thought cause I forgot I locked down the mac addresses... and was swearing, then ding... :eek:
  6. luckystephens macrumors member


    May 26, 2007
    I was able to join my wep encrypted network after a few attempts. The problem I had was that I was typing my hex key into the password field. There is a box to specifically enter your hex key. Hope that helps.
  7. JonboyDC macrumors regular

    Jul 19, 2004
    That's funny, I couldn't log into my wifi until I thought to try the hex key -- the regular password kept getting rejected.
  8. TheBusDriver thread starter macrumors 6502

    Dec 24, 2005
    whats the hex key?
  9. glxyjones macrumors regular


    Jun 29, 2007
    I'm having a similar problem...

    It found my network, I typed in my password (WEP 64-bit HEX) and it wasn't rejected. However, the iPhone constantly wants to connect to the EDGE network and not my wi-fi. I constantly see the "E" in the top left of the screen instead of the MAC wi-fi symbol.

    When I go to settings it sees my network and says I'm connected. I have no idea what I'm doing wrong. Maybe I should try retyping the password in, but I don't know how.

  10. marksman macrumors 603


    Jun 4, 2007

    I am having the same problem.

    I had a problem with the key at first, but when I used the $ on the hex it worked, but my iPhone refuses to use my home wifi network. It is always using the Edge. And I can not figure out why. For about 2 minutes once it used the wifi but that is it.
  11. sportseye@mac.c macrumors newbie

    Jun 29, 2007
    thanks JonboyDC!

    This was the difference for me! Thanks!
  12. seamuskrat macrumors 6502a


    Feb 17, 2003
    New Jersey USA
    Actiontec Verizon Fios here and same issue. i do use WEP and no go.

    I use the key id 10 digits. In the Actiontec I have no means to get the longer hash id.

    But I am sure its an issue with the router, but sucks all the same.

  13. TheBusDriver thread starter macrumors 6502

    Dec 24, 2005
    ok got it to connect to the Wifi but now it says server not found when i try to go anywhere.
  14. iprincess macrumors member

    Jun 25, 2007
    make sure you are entering the password correctly. unfortunately it does not tell you if you enter the wrong password. i had trouble last night i had to enter a long hex code and it was a challenge to get it entered correctly. what i did notice is that once the password is entered correctly, the wifi icon shows up top but also the spinning circle next to the wifi setting does not spin. when the password is wrong, it sits there and spins. try to keep re-entering your password. use your pinky if you have to so you can be really precise. it's annoying but once it's in you are done. good luck!
  15. iprincess macrumors member

    Jun 25, 2007
    that means it's the wrong password
  16. TheBusDriver thread starter macrumors 6502

    Dec 24, 2005
    I'll check that.
  17. TheBusDriver thread starter macrumors 6502

    Dec 24, 2005
    I love you, Thanks for all the help its working now. After a router refresh putting it in the hex key and makeing the password right.:D

    iPhone yaaaaaa!:p :apple:

  18. Rangerdeputy macrumors newbie

    May 17, 2007
    I do not have a password for my router and it still says server not found whenever I try to browse anywhere.

    I have a netgear router I bought a few weeks ago from best buy. Works great for everything else.
  19. daveporter macrumors regular

    Sep 8, 2006
    Green Cove Springs, FL
    I also had a problem getting my iPhone to see my Wi-Fi network. Believe it or not, the problem is that the brand new, high tech, flagship Apple iPhone DOES NOT SUPPORT 802.11n!!!!!

    See my post here:


  20. sprocket003 macrumors newbie

    Jun 25, 2007
    iPhone just can't see any active networks

    I have no encryption at all at home but iPhone doesn't even see ANY networks that are active nearby. Wifi worked for a bit yesterday but now can't see a thing. I have still found no solution and it seems the iPhone tech support is closed.

    My About settings show that Wifi has a MAC address but it simply shows no list of available networks. Any solutions?
  21. Flowbee macrumors 68030


    Dec 27, 2002
    Alameda, CA
    Very strange. I bought two phones. My wife's connected to our Airport Express right away, no problems. Mine won't connect. I've tried entering the regular password and the hex password. No love. I'm currently restoring my iPhone software and will try again.
  22. plumbingandtech macrumors 68000

    Jun 20, 2007
    since for some strange reasons they keep your password as **** when you type it is VERY EASY to make a mistake.

    I had to type mine twice and the 2nd time i was VERY careful.

    they should change this to plain text.
  23. mkrishnan Moderator emeritus


    Jan 9, 2004
    Grand Rapids, MI, USA
    The worst example of this is when WAP sites expect you to enter an alphanumeric password, using T9 / predictive input on a cell, without seeing what you're typing. Yeah, that'll work out great. :rolleyes:™
  24. tribe3 macrumors 6502

    Nov 1, 2005
    Vienna, VA - USA
    Same here. An "E" and not the Airport "fan". I can send emails from the .mac account; Internet is so slow that it's impossible.; youtube says that EDGE failed or "movie can not be played.

    I have an Airport extreme to a cable modem and 6 computers (5 Macs and 1 peecee) connected wireless. My connection speed on the computers is FAST (9300kbps!!)

    EDIT: Now it's connected to wi-fi but it can't open page or send emails because "It cannot connect to the server"

    Anyone in the same situation?
  25. seany916 macrumors 6502

    Jun 26, 2006
    Southern California
    can't connect to my WiFi

    I enter my WEP password, the E for Edge turns into the WiFi fan, then when I try to connect it to anything, it switches back to Edge even though it accepts the WEP password. Haven't tried it in any free WiFi networks yet though.

Share This Page