Won't Let Me Make Alias

Discussion in 'iMac' started by agentwitt, Feb 13, 2011.

  1. agentwitt macrumors newbie

    Joined:
    Feb 13, 2011
    #1
    I recently bought a new iMac and used Migration Assistant to transfer all the data from my MacBook. There are some quirks, however. For instance, I cannot make an alias of any of the folders in my Home folder, such as the documents or pictures folders. I can make aliases of folders inside those folders, but not of the parent folder itself. For instance, I can't make an alias of the documents folder, but I can make an alias of any folder inside of the documents folder. I was able to do this on the MacBook, so I'm not sure what changed when using Migration Assistant. When I try to make an alias for the folder, the option is gray and unable to be highlighted from the file menu...also, I can't do option command and drag....that just copies the folder to the desktop. Is there a setting that I have messed up or something? Thanks for the help!
     
  2. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #2
    Sounds like something is wrong with the home folder permissions. Boot to your Mac OS Install DVD (for the iMac), and from the Utilities menu select the Reset Password option. You are not actually going to reset the password but there will be a button for resetting home folder permissions and ACLs. After, quit the installer and restart your Mac and re-test.
     
  3. agentwitt thread starter macrumors newbie

    Joined:
    Feb 13, 2011
    #3
    You are right, the problem was with folder permissions. I selected 'Get Info' on the Home folder, then under 'Sharing & Permissions' changed 'Staff' from read only to 'Read & Write.' That seems to have fixed the problem...I'll update if I find any issues
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    Staff is supposed to be read only. There should have been something there with your user shortname which has read & write permissions. The everyone group should be No Access.
     

Share This Page