Won't sleep; flash slow; can't screenshot? - caused by Radeon 4890?

Discussion in 'Mac Pro' started by Yorb, Jul 3, 2010.

  1. Yorb macrumors newbie

    Yorb

    Joined:
    Nov 13, 2009
    Location:
    Raleigh, NC
    #1
    I've had a couple of problems recently that I'm wondering if anyone else with a flashed Radeon 4890 has experienced. First of all, I've had the 4890 for months, and it works fine otherwise and none of these problems are present on the Windows side.

    1. If I leave it by itself, it will never sleep. The monitor won't even dim. If I choose Sleep from the :apple: menu, the screen goes black as expected but then it locks up. I can't wake it up and have to hold power to shut down. If I choose Lock Screen from the keychain app menubar icon, absolutely nothing happens (if you don't have it, you can enable this helpful icon by opening Keychain Access and going into Preferences).

    2. Full-screen flash is really jerky and slow. I've fixed that somewhat by setting Flash to use not use hardware acceleration. It's still a little jerky, but much much better than it was. Still almost worth booting into Windows to watch any sort of Flash-based video (Hulu, Netflix, YouTube, etc.).

    3. Whenever I try to take a screenshot, it doesn't save the file anywhere. If I try to use Grab.app, the resulting picture is completely white. This happens with screen, window, and selection modes.

    Possibly unrelated issue that's being going on for a long time: my Mac Pro periodically freezes if I leave it alone all day. As in, I never see it crash, but I will frequently come home from work or something to find it in this state. It's not totally frozen, I can still move the cursor and switch applications, but if I try to quit apps or open new apps, I get the beachball and it will be completely dead within 30 seconds or so. The only reason I think this may be related is because it never crashes while I'm using it, which leads me to think it happens when it tries to sleep or something.

    Oh, and yes it happens even if I boot in safe mode. And I've tried resetting the SMC. :(

    Any help? Thanks :)
     
  2. Cindori macrumors 68040

    Cindori

    Joined:
    Jan 17, 2008
    Location:
    Sweden
    #2
    Check Zeus for driver support, if not, install
     
  3. Yorb thread starter macrumors newbie

    Yorb

    Joined:
    Nov 13, 2009
    Location:
    Raleigh, NC
    #3
    Thanks, I'm only now getting back to this because I've been busy and only really used my computer for illustrator, photoshop, web browsing, and windows for gaming. So I just put off fixing it. :p

    I tried using the current version of Zeus to reflash, install/remove Natit (tried both ways), and install the QE_CI Exotic patch for 10.6.4. It still says Quartz Driver Installed: NO. Everything else still works fine, but this list of issues is still plaguing me:

    • Screenshots don't save
    • Preview.app only shows blank windows (quick look is fine)
    • Computer crashes/freezes/becomes unresponsive frequently (at least once a day if I leave it on in OS X)
    • Games don't open anymore (COD4 bounces once and quits, Warcraft 3 says it had trouble initializing OpenGL, and to check that my OpenGL drivers were installed and current.
    • Photobooth runs fine when first opened but becomes increasingly jerky and I can hear my HD going nuts clicking all the time and it becomes almost totally unresponsive after a minute or so. Switching to the photo viewing screen (so no camera feed is displayed) fixes it until I go back to the camera feed.
    • iChat crashes on trying to start a video conference, or opening the video preview window.

    I ran Disk Utility and it said there were some problems so I booted from the SL disc and ran Repair Disk from there, it said it fixed everything.

    I also ran the 10.6.4 combo updater because some people said that fixed the preview.app blank images issue. No such luck for me. I've tried booting in safe mode too, no luck.

    Help! :( Thanks.
     

Share This Page