Won't Sleep or shut down

Discussion in 'MacBook Pro' started by estee065, Sep 16, 2007.

  1. estee065 macrumors member

    Joined:
    Jun 26, 2006
    #1
    I have a macbook C2 2Gig w 1gig of RAM. Every so often (usually right after disconnecting from the power cable, which is weird), I will hit cmd option eject to put it to sleep and nothing happens. I select sleep from the menu, and nothing happens. Even closing the lid doesn't work. If I select shut down, nothing happens. The only way to shut the computer off is to hold the power button until it turns off.
    I found some answers before, which involved deleting some files from the preference folder, and it seemed to work for about a week, but the problem popped up again yesterday. Any suggestions?
     
  2. jvencius macrumors regular

    Joined:
    Jun 28, 2007
    #2
    When my MBP was doing those exact same things I ended up with a completely new machine. The Apple tech I was on the phone with had me run some tests (I'm so new, I don't know/remember what they were) and after they were done he said there was nothing he could do to fix it since it was a hardware problem.
     
  3. estee065 thread starter macrumors member

    Joined:
    Jun 26, 2006
    #3
    Thanks for the reply. I hope it isn't hardware related. Anyone else with this problem?
     
  4. lucasc896 macrumors member

    Joined:
    Jul 30, 2007
    #4
    I've got a similar problem with my SR MBP. It keeps waking from sleep randomly and then not working, and then coming back to life after about 2-3 minutes (only sometimes).

    I tried posting about it, but looks like no-one could help. I'll give apple a call.
     
  5. estee065 thread starter macrumors member

    Joined:
    Jun 26, 2006
  6. lucasc896 macrumors member

    Joined:
    Jul 30, 2007
    #6
    I called apple and we went through a few diagnostic tests. They decided I should take it in to my local repair centre. Their idea was that it was either something to do with the sleeper switch or some other hardware fault, but as the guy on the phone had never seen the inside of a macbook he didn't know.

    In the end I didn't leave it with them because they were going to take 10 days to diagnose the problem, but I'm going to uni in 9! So I figured I would live with the problem and get it fixed later.
     
  7. paulbaker macrumors regular

    Joined:
    May 4, 2007
    #7
    My MB just strarted not going to sleep out of the blue....

    When I select sleep from the Apple menu, nothing.
     
  8. pacer204 macrumors newbie

    Joined:
    Nov 1, 2007
    Location:
    Tunbridge Wells, Kent
    #8
    MBP not shutting down after leopard install

    I've had a similar problem since doing an erase and install of Leopard at the weekend.

    I have no problem with sleep but with shut down it's a different matter.

    I press the power button, select shut down, all starts to go fine until the desktop disappears and the timer circle appears and never goes (not the marble of doom, the other one), I left the MBP over night and it was still trying to shut down this morning! I had to hold down the power button to turn the damn thing off. I then tried a restart which went fine. I then tried Shut down again and all was fine.

    I saw that relaunching finder before shutting down helps but I dont know if this really works.

    My issue has only happened when the MBP has been used and only slept for a few days, when I try to shut down after this, it just cant be bothered, cananyone shed any light on this.

    Thanks.
     
  9. doug.hall macrumors regular

    Joined:
    Jul 28, 2005
    Location:
    London
    #9
    I have the same issue and this is the second SR MB with the problem. There is certainly something not right but I have no idea what it is:confused:
     
  10. jameskohn macrumors 6502

    Joined:
    Sep 11, 2006
    Location:
    Connecticut
    #10
    I have a similar problem with my MacPro after upgrading to Leopard. I have found that if I click the little apple in the upper left corner of the screen, then click shut down, then instead of clicking in the dialog window to confirm shut down I just leave it alone. It shuts down fine. If I do click in the dialog window to confirm shut down, it hangs as you described with the spinning gear on the screen. Sounds like a software/O.S. issue. By the way, do you have an external drive connected, perhaps for time machine? I have noticed that if I eject my external HD then turn it off, I can click shut down in the dialog box and it works fine.
     

Share This Page