Won't sleep when Internet sharing (after Mavericks upgrade)

Discussion in 'Mac Pro' started by macstatic, Mar 20, 2015.

  1. macstatic macrumors 6502a

    Joined:
    Oct 21, 2005
    #1
    I've just upgraded (clean install) my mid-2010 Quad core Mac Pro from OSX 10.6.8 Snow Leopard to 10.9.5 Mavericks, and now sleep does't work.

    Having read this thread about the subject I tried several things (including SMC reset, PRAM reset, checking/fixing permissions). Since none if this worked I issued the following terminal command and results:

    Code:
    $ pmset -g
    Active Profiles:
    AC Power		-1*
    Currently in use:
     hibernatemode        0
     womp                 0
     networkoversleep     0
     sleep                30 (sleep prevented by InternetSharing)
     Sleep On Power Button 1
     ttyskeepawake        1
     hibernatefile        /var/vm/sleepimage
     autorestart          0
     disksleep            10
     displaysleep         10
    If I open the "Sharing" preferences, disable Internet sharing and check again it looks OK:

    Code:
    $ pmset -g
    Active Profiles:
    AC Power		-1*
    Currently in use:
     hibernatemode        0
     womp                 0
     networkoversleep     0
     sleep                30
     Sleep On Power Button 1
     ttyskeepawake        1
     hibernatefile        /var/vm/sleepimage
     autorestart          0
     disksleep            10
     displaysleep         10
    I use the Ethernet 2 socket on the rear to attach a laptop to my network and have never had this problem with OSX Snow Leopard. Is there a solution to this problem?
     
  2. DougTheImpaler macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #2
    When I go to turn on internet sharing, it tells me this. So it seems yours is working fine.

    (Computers connected to AC power won't sleep when Internet Sharing is turned on.)

    I'm on Yosemite, but my guess is it's true of Mav too.
     

    Attached Files:

  3. macstatic thread starter macrumors 6502a

    Joined:
    Oct 21, 2005
    #3
    I think I might have figured it out after doing a terminal "man pmset" where it says that the power management settings are stored globally and not per user in OSX, so I deleted the following file:

    /Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist

    Now I can put the Mac to sleep even with Internet sharing on, but it is it normal that it takes a while for sleep to kick in (after selecting "Sleep" in the Apple menu)? In Snow Leopard it was almost instantaneous (a couple of seconds usually) while now, in Mavericks it takes around 20 seconds of waiting. Any caches I could flush or something?

    ----------

    You're right! It says the same thing here in Mavericks.
    However, trashing that pref file did fix something. Or did I break something (since Apple says it shouldn't sleep) ;)
    I can't remember what it says in Snow Leopard, but I was able to put the Mac to sleep with my laptop attached.
     
  4. DougTheImpaler macrumors 6502a

    Joined:
    Feb 28, 2006
    Location:
    Central Illinois
    #4
    I wonder if it's turning off sharing before it sleeps. Try putting it to sleep with the preference pane open. If it's taking a while you might see it disable ICS before it sleeps. If so that might explain it.
     
  5. macstatic, Mar 20, 2015
    Last edited: Mar 24, 2015

    macstatic thread starter macrumors 6502a

    Joined:
    Oct 21, 2005
    #5
    When I choose "Sleep" (from the Apple menu) the display goes black immediately while the Mac itself keeps on running (fans and hard drives spin, white power LED lights constantly) for another 20 seconds or so, so it's hard to say what happens. But when I turn on the computer again it seems nothing is changed, so it might keep track of things and turn it off while sleeping, then on again.

    EDIT: I don't know what happened, but I'm again no longer able to make it sleep with Internet sharing enabled. Frustrating as I often connect my laptop to the Mac Pro via an Ethernet cable connected to Ethernet 2 and it would be nice if I don't have to enable/disable Internet sharing all the time, but just let it stay on. Is there a solution to this that won't affect sleep?

    I tried booting into OSX Snow Leopard 10.6.8 again and see that there's no warning about sleep not being available when Internet-sharing. Perhaps there's a hidden feature in OSX 10.9 which allows this to be set the same way?

    I also noticed that setting my Mac to sleep with 10.6.8 was near instantaneous (1 second or less).
     

    Attached Files:

Share This Page