Won't sleep with vmware fusion running?

Discussion in 'Windows, Linux & Others on the Mac' started by Macloven, Sep 23, 2008.

  1. Macloven macrumors regular

    Macloven

    Joined:
    Aug 25, 2008
    #1
    Sorry if this is a cross post, as I thought this was a MBP issue but apparently not. I've isolated the sleep problem to existing only when VMware is running.

    If I have windows loaded in the Fusion window, the machine won't sleep. The screen goes out, but it keeps running until the battery hits 0%. this is crashing windows...not a happy thing.

    When I select sleep from the file menu, it will go to sleep properly...just not by itself. This feature had worked for the last couple of weeks, and just turned up when I both replaced the logic board and updated to 10.5.5. I do seem to recall it working after the new motherboard, before 10.5.5 but not positive.

    I've reloaded the vmware tools which didn't help. Any direction to go here to get this feature working again? While I considered the genius bar, thinking they'll point me to the VMware people as the sleep function works fine without fusion running.

    TIA,

    Mark
     
  2. Markov macrumors 6502

    Markov

    Joined:
    May 18, 2007
    Location:
    Philadelphia
    #2
    I'm pretty sure that's normal. I'm almost certain VM Ware will keep your computer from sleeping, or at least while the VM is running. Try suspending the machine and then putting it to sleep. Obviously you cannot have the virtual Machine run while the laptop itself is asleep... Or I would hope that's obvious to you. haha
     
  3. Macloven thread starter macrumors regular

    Macloven

    Joined:
    Aug 25, 2008
    #3
    Before my 10.5.5. upgrade and new motherboard, it would go to sleep by itself. It will sleep if I select it from the file menu...but I can't always remember to do that. Things happen during the day, and next thing you know the battery is dead.

    There is nothing running in the VM Ware window other than the XP OS. Presently playing with the timing of when XP goes on standby to see if XP standby will let OSX then go to sleep. So far, no luck but still tinkering.

    Mark
     
  4. Macloven thread starter macrumors regular

    Macloven

    Joined:
    Aug 25, 2008
    #4
    Looks like this may be solved...thanks to Markov for the comment about suspending things first.


    1. Went into XP control panel and put power savings to suspend a few minutes faster than OSX.

    2. In VMWAre settings, clicked the box to have OSX battery settings passed thru to XP.

    Note that I didn't do any of this prior to the OS update and it worked fine, but perhaps 10.5.5 is more particular about such things.

    Whatever the case, the machine is going to sleep when it's supposed to, staying cool and not running the battery. It has worked a couple times now, so may be problem solved :)


    Mark
     
  5. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #5
    Sorry to interrupt, but I noticed you're running bootcamp/fusion. i have a boot camp partition of vista ultimate and was thinking of putting it thru fusion as well. how did you get urs to work? I have heard some problems regarding the activation..
     
  6. Macloven thread starter macrumors regular

    Macloven

    Joined:
    Aug 25, 2008
    #6

    Happy to say that getting it to work in Fusion was as simple as installing Fusion and starting it up. Fusion saw the Bootcamp partition in the startup screen and I selected it. It had me load the VMware tools and that was it. Yes, I've had to fine tune it, but otherwise effortless. As VMware is a free download to try.....give it a shot. I've allocated 1.5 gig RAM to XP and it runs great. I did have to activate XP again in Bootcamp, but was able to do that with the phone number/automatic activation that came up in Windows.

    Mark
     

Share This Page