Won't start- power supply?

Discussion in 'iMac' started by gravyboat, Nov 26, 2010.

  1. gravyboat macrumors member

    Joined:
    Nov 26, 2005
    #1
    Tried to wake my 24" white iMac from sleep yesterday and discovered that it was off. Pressed the button in back but no go. Unplugged and replugged, pressed the button and it fired up fine. Surfed a bit, then put it back to sleep.

    Came back about 3 hours later and it was off again. Unplugged and replugged, pressed the button and nothing. Tried it a couple more times just to check, and no go.

    Any ideas? I've had this computer for a little over two years. Bought it used and bought Applecare which expired on.... Nov. 16th. Beautiful timing or what.

    Thanks very much for any help on this.
     
  2. biggd macrumors 6502

    biggd

    Joined:
    Apr 6, 2008
    Location:
    Calgary
    #2
    Yes. PSUpply
     
  3. gravyboat thread starter macrumors member

    Joined:
    Nov 26, 2005
    #3
    Thanks for the reply, biggd. I see that it's about $100 online, hopefully I'll be able to figure out how to install it myself.

    Also appreciate the ifixit link.
     
  4. biggd macrumors 6502

    biggd

    Joined:
    Apr 6, 2008
    Location:
    Calgary
    #4
    It's not 100%.
    And it could be bad motherboard, but most of the time it's a power supply
     
  5. gravyboat thread starter macrumors member

    Joined:
    Nov 26, 2005
    #5
    Yikes-- let's not talk about logic boards. Lost my G5 iMac to melted capacitors.

    I'm going to give the power supply a shot. If it's the board, it's going to be too expensive to fix anyway. Thanks again.
     

Share This Page