Word 2004: Unicode Font Help?

Discussion in 'Mac Apps and Mac App Store' started by bhwalker, Nov 26, 2007.

  1. bhwalker macrumors newbie

    Joined:
    Nov 26, 2007
    #1
    I am a medievalist specializing in Old English and Old Norse, and I require special fonts for use of certain characters in word processing programs. I recently downloaded the mac version of the Junicode font (description found Here: http://junicode.sourceforge.net, downloaded from here: http://sourceforge.net/project/showfiles.php?group_id=158636&package_id=177880&release_id=525493).

    When I try to use the font in Word:Mac, however, the special characters do not show up. I have tried to copy and paste some Old English text from the internet (where it appears correctly), but this proves unhelpful.

    Does anyone have troubleshooting suggestions or recommendations to help me fix this problem?
    (I have a MacBook and run OS X 10.4.11.)
     
  2. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #2
    So you've got the Junicode.dfont file downloaded, I assume. Then what did you do with it?

    Try putting it in manually, into /Library/Fonts. The Library at root level of your hard drive and then restarting the machine.
     
  3. bhwalker thread starter macrumors newbie

    Joined:
    Nov 26, 2007
    #3
    Yes, after I downloaded the font file, I put the font in the root Library/Fonts directory and have restarted. This didn't change anything.
     
  4. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #4
    This might sound silly but you did unzip the file, right? I've gotta ask...

    Does the font render properly in any other piece of software, TextEdit, for instance? Have you tried using the platform-independent file? junicode-0.6.15.zip?
     
  5. bhwalker thread starter macrumors newbie

    Joined:
    Nov 26, 2007
    #5
    Sorry, I don't think that I explained the details of my problem well enough here. I'll try to provide some more details.

    I did unzip the file, and it does render correctly in both FontBook and Word (my primary word-processor). The biggest problem is not being able to see and/or insert the symbols for the "thorn" (þ) and "eth" (ð) characters (medieval Germanic symbols) in Word:Mac. I know that this is possible in Word on a PC, but inserting and viewing these characters in Word:Mac is impossible for me at this point.

    The standard way to insert these characters is to go to the menu "Insert" and then "Symbol," find the symbol, then insert it. However, these two symbols do not show up in the symbol listing. When I try to copy and paste these symbols (from the internet, for example--where they do show up correctly), they copy only as the underscore symbol (_). Perhaps this helps clarify. The problem is not specifically with the font, but is with the rendering of these specific symbols in the program.

    I hope this clarification helps.
     
  6. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #6
    OK, those two are glyphs. I've opened the font up in a font utility I have for viewing glyphs, characters and symbols. This is a Unicode font. Be warned, this gets ugly.

    Read this as background: http://word.mvps.org/Mac/Unicode.html

    00DE is the Unicode for the thorn ( Þ ) Glyph 160
    00F0 is the Unicode for the eth ( HTML ð ) Glyph 178

    Word 2004 supports Unicode, but I'm not a Word guru... I've done a bit of searching for you, but haven't found out how to use Unicode characters in Word 2004.

    I sympathise and have a little background in this. A friend of mine is doing her doctorate in Medieval English and also asked me for the same help a few years ago... I couldn't solve it at the time, but second time round, some of the mystery is becoming clearer.

    Edit: I've clarified your thread title and am going to move this into Mac Applications where it might get a better response as it's definitely a Word 2004 issue.
     
  7. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #7
    OK, have got it to work in Word 2004.

    Go to System Preferences>International>Input Menu.

    Scroll right down and enable Unicode Hex Input with the 'show input menu in menu bar' option selected at the bottom.

    Then, close that and go to the menu bar at top right, select the Unicode Hex Input option. Open up a Word document, hold down the Option (Alt) key and type in the 4-figure hex code for the characters.

    You can then revert to your normal keyboard layout and copy and paste the characters as you go, if you like, or type the characters in using the above method.

    :)
     
  8. bhwalker thread starter macrumors newbie

    Joined:
    Nov 26, 2007
    #8
    Problem solved; and now I know how to figure out just about any symbol I may need in the future--Runes, Latin characters, etc. will also be helpful, now that I know where to access all of my hex needs.

    Thanks for all the time you spent researching this for me, and for the willingness to help.
     

Share This Page