Word 2008 high CPU usage = crazy fan activity

Discussion in 'Mac Apps and Mac App Store' started by MerrieLu, Jul 27, 2008.

  1. MerrieLu macrumors newbie

    Joined:
    Feb 5, 2008
    #1
    Whenever I run Word for more than 10 minutes my fans start going crazy and Word uses about 89% CPU. My fans usually never turn on otherwise and it really sounds like the poor thing is going to explode any minute. :eek:

    Here are my specs:

    Model Name: MacBook
    Model Identifier: MacBook3,1
    Processor Name: Intel Core 2 Duo
    Processor Speed: 2.2 GHz
    Number Of Processors: 1
    Total Number Of Cores: 2
    L2 Cache: 4 MB
    Memory: 2 GB
    Bus Speed: 800 MHz

    MS Word 2008 Student Edition

    I have heard that it has something to do with spotlight. But I really don't have a clue what I am doing. PLEASE HELP! :confused:
     
  2. Muncher macrumors 65816

    Muncher

    Joined:
    Apr 19, 2007
    Location:
    California
    #2
    Try Applications > Disk Utility > Click on your main drive > Repair Permissions. That could do something, and it never hurts to do this about once a month.
     
  3. MerrieLu thread starter macrumors newbie

    Joined:
    Feb 5, 2008
    #3
    Thank you for the suggestion, but it didn't seem to help :(
    Anyone else got any ideas? I've also posted on the "Mactopia" website but they seem to be somwhat useless.
     
  4. tmelvin macrumors 6502

    tmelvin

    Joined:
    Mar 17, 2008
    #4
    I used Word for hours at a time, and no change in fan speed, etc.

    Did you update Office? There's a 12.1.1 update I believe. If not, I'd update it to the latest revs and then retry.
     
  5. MerrieLu thread starter macrumors newbie

    Joined:
    Feb 5, 2008
    #5
    Word is set to update automatically and I am already running version 12.1.1.
    I should also mention that the CPU usage is only high when I am looking at a document. If I bring another program to the front, it goes right down under 10%. Otherwise, I could show you guys a screenshot.
    Anybody else got some suggestions? Thanks!
     
  6. MerrieLu thread starter macrumors newbie

    Joined:
    Feb 5, 2008
    #6
  7. Father Jack macrumors 68020

    Father Jack

    Joined:
    Jan 1, 2007
    Location:
    Ireland
    #7
    Surely it must be something other than Word that's taxing your system, after all any old system should run a WP program without breaking into a sweat .... :confused:
     
  8. MerrieLu thread starter macrumors newbie

    Joined:
    Feb 5, 2008
    #8
    AHA!

    If I turn the "Check grammar as you type" option off, the CPU goes back down to under 10%! Turn it back on and it shoots back up to 90%.
    It must have to do with the fact that I am writing in German and I guess, Word just doesn't like it.
    Well, that sucks. Thanks MS for the downgrade from 2004.
     
  9. Muncher macrumors 65816

    Muncher

    Joined:
    Apr 19, 2007
    Location:
    California
    #9
    That's just lame, MS. :mad::D:rolleyes:
     
  10. Sir Timm macrumors newbie

    Sir Timm

    Joined:
    May 7, 2009
    #10
    I have the identical crazy-fan problem. Only difference: I had it when writing in English, though word was set to German as standard language for spelling an grammar: 80 to 90% CPU usage.
    Now that I have changed the standard language to English, it's a little less, around 40% which does not cause the fan to go wild any more.
    As soon as I switch online grammar check off, the CPU usage goes down to 5 - 8%.
    Bad thing about this: it's not just the annoyance by the fan but also the battery, that's down in no time if CPU usage is high all the time.
     
  11. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
  12. jeffreyf macrumors newbie

    Joined:
    Jan 14, 2010
    #12
    Thank you!

    I just joined the forums to say thank you for figuring this out.

    I have a MBP with 4 gigs of ram, and Word was still using 98%+ of my CPU at times. Turning off grammar check as I type shot this down to under 10%.
     
  13. AQP88 macrumors newbie

    Joined:
    Feb 17, 2010
    #13
    CPU problem

    I have the same crazy-fan problem. I turn the "Check grammar as you type" option off, but nothing changes. I reinstall office 2008 3 time already, and still giving me the fan problem. Any suggestions???? Help please!!!!
     

Share This Page