Word 2011 - Copy & Paste text broken

Discussion in 'Mac Apps and Mac App Store' started by Frozzie, Mar 23, 2012.

  1. Frozzie macrumors regular

    Joined:
    Jul 23, 2011
    #1
    It is ridiculous I can't even copy and paste texts in Word - it is the most important function that a computer user can imagine. How do I fix this so that I can copy & paste? The only solution is to press shift when I launch the application, but I shouldn't have to do that because it will exhaust me so much I will be tired.
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Have you rebooted your computer?
     
  3. Frozzie thread starter macrumors regular

    Joined:
    Jul 23, 2011
    #3
    I cannot see how it is going to make a difference - and I have rebooted. It makes no difference.
     
  4. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #4
    Have you tried safe mode? it's possible some other app is interfering, doubtful but possible.

    Does cut and paste work in other apps such as PowerPoint as wells non-Office apps?

    As a last resort, you can delete and reinstall Word.
     
  5. Frozzie thread starter macrumors regular

    Joined:
    Jul 23, 2011
    #5
    Of course it works on non-office apps. It also works in PowerPoint, but I don't see delete and reinstall as permanent solution because once in future it will happen again. If I can iron out this problem without having to go through all that hassle the problem is fixed - reinstall is just delaying the inevitable.
     
  6. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #6
    Have you checked your settings under the following menu options: Word>Preferences>Edit and then see if your setting there haven't changed, these are mine (the smaller settings box is revealed when you click the settings button under the Cut and Paste options):
     

    Attached Files:

  7. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #7
    What happens in safe mode?

    Have you done that and it came back?
     
  8. Frozzie thread starter macrumors regular

    Joined:
    Jul 23, 2011
    #8
    Have reinstalled about four times previously, so it is something that will come back in a matter of time and not a permanent solution.

    ----------

    Exactly same. Once again let me say the problem isnt there when i press shift before launching word. But i should not have to do that.
     
  9. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #9
    Then it's one of your settings - you need to reset all of Word's settings to their defaults; you may need to delete your Word preferences folder to do this. You can google how to do that.

    If it keeps coming back, then something is messing with your Word preferences. Not sure what would do that other than a .dot file maybe?
     
  10. Frozzie thread starter macrumors regular

    Joined:
    Jul 23, 2011
    #10
    Tried deleting preference (.plist) files and also Normal.dot like you said, but made no difference. I don't know any other way of deleting preference folders but even with google I didn't find anything new.

    Ended up reinstalling anyway. Let's see how long it lasts before same problem crops up again - hopefully by that time there is Office for Mac 2014 around.
     
  11. Frozzie thread starter macrumors regular

    Joined:
    Jul 23, 2011
    #11
    Even after reinstall problem came back again. From close observation this seems to have happened after installing update 14.1.4
     
  12. jlc1978, Mar 27, 2012
    Last edited: Mar 27, 2012

    jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #12
    WHat happens when you boot in safe mode?

    It may be the .14 release- I'm still at .13
     
  13. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #13
    OK - I just updated my Word (latest version) and have no cut and paste problems; which leads me to believe some other program is messing with your install. Any luck with safe mode boot of your Mac?
     
  14. Frozzie thread starter macrumors regular

    Joined:
    Jul 23, 2011
    #14
    Nope, it didn't make any difference. I can't see how safe mode can save it because on all other programmes cmd+v works as paste function.

    The only plugin I installed was Mathtype. And to give more details, I didn't install everything for Office 2011 (e.g. outlook, communicator, messenger) as I unticked few features that I don't use.
     
  15. jlc1978 macrumors 68000

    jlc1978

    Joined:
    Aug 14, 2009
    #15
    Safe mode, amongst other things, eliminates all startup items when booting - so if one of them is causing the problem it Word should behave normally. It's quite possible one program is causing the problem only in Word - SpellCatcher, for example, as issues with Outlook but generally works fine with other programs.

    So a safe boot would let you eliminate external programs that may be causing the issue. It seems you've done a safe boot and that didn't fix the problem, then it's probably an add-in to Word - have you removed all of them; including MathType? Did you install any earlier that may not have been fully removed from your system? Since Word works fine if you start it in t's safe mode that makes it even more likely to be an add-in you've installed.

    Since I am running the same version of Word, with no issues, it seems that it's a program or add-in that is causing your issue.

    As a side note - does mouse selected cut and paste work normally?

    Also - do you have any services installed that may trap cmd-v?
     
  16. Frozzie thread starter macrumors regular

    Joined:
    Jul 23, 2011
    #16
    It is MathType. I uninstalled it, then problem was gone.

    Problem is that I need it for my iWork that I use - but then I can't install MathType without installing it for Office as well. So what I am going to do - uninstall everything, Then Install iWork and MathType first before installing Office.
     
  17. tiredof macrumors newbie

    Joined:
    Feb 3, 2012
    #17
    I agree Mathtype may be the culprit.

    FIXED

    Having Word as the active application, go to Tools, Templates and Add ons, uncheck MathType, Press OK.


    ********************



    I agree that it is Mathtype but I am having the opposite problem. When I unintsalled Mathtype it broke the copy and past. I received a specific error on it,

    MathType Commands
    An error starting MathType's commands for Word. Please reinstall Mathtype.

    I on the other hand do not want it. I found the Math in Open Office to be easier to use. I have to check my settings, hopefully, i can find it and fix it.

     
  18. perelus macrumors newbie

    Joined:
    Aug 15, 2010
    #18
    Word 2011 - Copy & Paste text broken, will not print from Word

    Many thanks for the fix. In my case I found that Mathtype had stopped Word from printing and broke the cut and paste option.

    The printing options were just ignored in Word, but of course worked OK in Excel.

    I found that I had to delete the MathType Commands.dit file from here:
    /Applications/Microsoft Office 2011/Office/Startup/Word/MathType Commands.dot

    So far so good...
     

Share This Page