Word 2016 Dictionary Wrong, Can't Correct!

Discussion in 'Mac Apps and Mac App Store' started by Zandery, Mar 12, 2017.

  1. Zandery macrumors member

    Joined:
    Jul 25, 2016
    Location:
    UK
    #1
    I've just downloaded Office 2016 for Mac and when typing in Word it displays correct words as incorrect, by going into the language settings within Word, I changed the language to English (UK) however it keeps changing to Portuguese or German, both of which I don't write in.

    The dictionary is also set to custom, I can't find a place to download English (UK) anywhere or is it only meant to be custom?

    My system language is English (UK) on macOS, I've got no other languages installed and I've not had this issue in Pages either. As a reference point, Word as a whole is in English but not when typing.

    Does anyone know what could be wrong?
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    Have you looked in Word preferences? Word will normally use its built in dictionary which for you should be UK English. However, there is an option to add a custom dictionary for unusual words that are not normally in the built in dictionary. You should not have to download any additional languages if you purchased and downloaded MS Office 2016 in the UK. If the problem persists, uninstall Office 2016 and download - reinstall it again. Did you purchase the stand alone Office 2016 or the Office 365 version?
     
  3. Bending Pixels macrumors 65816

    Joined:
    Jul 22, 2010
    #3
    Another new "feature" from Microsoft
     
  4. Zandery thread starter macrumors member

    Joined:
    Jul 25, 2016
    Location:
    UK
    #4
    I looked everywhere and the only built in dictionary is Custom which seems moronic to me but c'est la vie. I got the Office package as part of Office 365, the online versions don't appear to suffer the same annoyances as the downloaded versions do.

    I've since uninstalled completely and use the Office 365 version but I may reinstall as I need to be able to work without internet connection sometimes (on the train for example). If that doesn't fix it, I'll wait until work issue new laptops and pick a Surface Pro 4/HP Spectre (they're removing desktops altogether!).
    It's a very good feature, it makes everything so much harder.
     
  5. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #5
    OP, I don't see that you have made one key workspace designation, and it's pretty much been set up this way as long as I've used Word (just short of 30 years…). I also see that you've just posted, but I'll continue. Look at the Tools>Language Dialog:

    Language.png
    It's set up for both (1) Global and (2) Per Session Language prefs. The latter setup is what I suspect that you're experiencing. For (1), select the Language you prefer to use all of the time by default, then click on the "Default…" option button - Word stores this in the Normal.dot Template File; IMO the switch to the other language is stored in that Normal Template, and you likely have just clicked "OK". For (2) by clicking "OK" you're saving your preferences in the open Word file only, and this "per session" Language is stored in the header of that open Word file.

    So, put another way, your Normal Template is telling Word that your default language is German/Portuguese, and you're selecting English (UK) for the "dictionary" for your preferred German/Portuguese workspace so you now have a Custom Dictionary inside the German/Portuguese DE or PT Resource folders in the Word app package. Word is broken down into language support files - the Default proofing tool structure is that the proofing tools for the Default Language are the same as that Default Language, unless you choose a different set of proofing tools in which the result is a custom library stored alongside the Default Language proofing tools in the relevant Resource folder.

    You need to select the Language you want to work with, then make it the Default. Doing this will also select the appropriate Proofing Tools (spelling, grammar). Word will confirm that you want to make this change and notify you that the change will be reflected in the Normal Template.

    Supplementing this, any documents you have worked on in this fashion, with German/Portuguese as the default language will have either of those languages and custom dictionaries embedded in their headers. Once you have your Global workspace sorted, create a New document, open your already-created document(s) and "Copy" then "Paste Special…" (not Paste) and select the text option - you might not want to copy everything in your source document including the potentially-unwanted hidden heading information.

    You can also consider unchecking the "Detect language automatically" option in that Language dialog box; I work with non-native writers and am multi-lingual (including Portuguese), so I leave that box checked. My global preference is US English, but I also work on per-session documents in Word and Excel regularly and adjust the document's preference by selecting the "OK" option and not selecting the "Default…" option; the ellipsis at the end of that option means that there will be a dialog to follow after selecting that option, FWIW.

    I'm not going to surmise how the change to another language occurred. Cheers.
     

Share This Page