Word Docs to Auto Open in Pages

Discussion in 'Mac Basics and Help' started by soccersquirt82, May 18, 2008.

  1. soccersquirt82 macrumors 6502

    Joined:
    Mar 11, 2008
    #1
    I just got iWork, and I love it as it's much faster than MS Office. I would like all my Word, Powerpoint, and Excel Documents to automatically open, respectively, in Pages, Keynote, and Numbers. I know I can right click and say open with, but is there a way to open it in the iWork application just by double clicking?
     
  2. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #2
    Highlight a file in finder, press Apple+I to bring up the info window.

    Change the Open with, and then select Change All.
     
  3. soccersquirt82 thread starter macrumors 6502

    Joined:
    Mar 11, 2008
  4. soccersquirt82 thread starter macrumors 6502

    Joined:
    Mar 11, 2008
    #4
    What about downloaded documents? I would love to double click on them and open them in Pages. Instead, I have to drag it to my desktop and do "Open With." I tried the "Always Open With" when told "Open Other," but I must set this for EVERY Word document.
     
  5. soccersquirt82 thread starter macrumors 6502

    Joined:
    Mar 11, 2008
    #5
    There HAS to be a way to do this. It's just changing the default to Pages instead of MS Word. How do you do that?
     
  6. varmit macrumors 68000

    varmit

    Joined:
    Aug 5, 2003
    #6
    What the other person told you should have done just what you are asking. If you hit the change all, then any .doc file should open with pages. If they are .docx or another format then they didn't get changed over to being opened with pages. Also, is your MS Office that trial version or is it a full purchased version. If its a trial, go ahead and delete it from your Applications folder and it will help keep Word from opening the files.
     
  7. soccersquirt82 thread starter macrumors 6502

    Joined:
    Mar 11, 2008
    #7
    The setting to open in Pages isn't there with newly downloaded documents that my teacher gives me. I must do the setting for it to work on every new document.
     
  8. soccersquirt82 thread starter macrumors 6502

    Joined:
    Mar 11, 2008
    #8
    I downloaded a system preference called Default Apps and it worked. Finally!
     
  9. soccersquirt82 thread starter macrumors 6502

    Joined:
    Mar 11, 2008
    #9
    Also, how do I make a default preference for the margins? The margins are wider in Pages than in Word.
     

Share This Page