Word freezing on right click for spell check (SugarSync problem??)

Discussion in 'Mac Basics and Help' started by MacBookReboot, Oct 21, 2009.

  1. MacBookReboot macrumors newbie

    Joined:
    Nov 7, 2008
    #1
    I've been using Microsoft Word (Word 2004 for Mac, Version 11.5.5) for about two and half years with no problems... starting this morning, whenever I right-click a word for spellcheck, Word freezes and I have to force-quit. I've restarted, checked updates, and am at a loss. Leopard (not Snow) and Word both have all current updates.

    Has anyone else experienced this problem or have any ideas of what the issue might be?

    Thanks!
     
  2. MacBookReboot thread starter macrumors newbie

    Joined:
    Nov 7, 2008
    #2
    Anyone?

    Still doing the same thing today. I'm thinking about reinstalling Word, but if anyone has a better suggestion, I'd appreciate it. Thanks!
     
  3. splitpea macrumors 6502a

    Joined:
    Oct 21, 2009
    Location:
    Among the starlings
    #3
    Two things to try first:

    1) back up and then delete all your preferences for Word, and see if the problem persists.

    2) create a fresh user account and see if you have the same problem when running it as that user -- if not, it indicates that some setting in your account is at fault.
     
  4. MacBookReboot thread starter macrumors newbie

    Joined:
    Nov 7, 2008
    #4
    Thanks for the suggestions, but I now think that my SugarSync Manager is the culprit.

    I remembered that I updated the software this weekend... sure enough, when I quit SugarSync Manager, the Word spell check problem vanishes... odd.

    Any SugarSync users out there?
     
  5. MacBookReboot thread starter macrumors newbie

    Joined:
    Nov 7, 2008
    #5
    FYI - after I quit and restarted SugarSync Manager, the problem seems to have cleared itself up. Oh, happy day!
     
  6. H&E macrumors newbie

    Joined:
    May 20, 2006
    #6
    x2

    This problem had been plaguing me for a couple weeks now. Restarting SugarSync did the trick. I can't tell you how glad I am to have found your post.

    After the initial fix, have you had the problem recur at all?
     
  7. MacBookReboot thread starter macrumors newbie

    Joined:
    Nov 7, 2008
    #7
    Glad you found the post; the problem was driving me crazy. So far, so good - no recurrences.

    I contacted SugarSync about the issue, so hopefully they're taking a look at it.
     
  8. MacBookReboot thread starter macrumors newbie

    Joined:
    Nov 7, 2008
    #8
    Scratch the no recurrence part; SugarSync is acting up again. (Again fixed by quitting and restarting SugarSync).
     
  9. barlafus macrumors newbie

    Joined:
    Oct 31, 2009
    #9
    spanish accents in word 2004

    Hi MacBookReboot,
    I have a similar issue with word 2004. I am using the spanish language settings, and the document I am working with freezes any time I type an accent. It's crazy, and annoying too, as I have to force quit and loose part of what I have typed. I don't have SugarSync installed though.
    I found a solution suggesting uncheck 'Check spelling as you type' that I have just done. Is working fine for the moment. But I like the option I had to uncheck. Other people were suggesting this, but I am not sure is my case:
    http://word.mvps.org/Mac/DocumentCorruption.html
    Does anyone have a similar issue with the spanish accents?
    Thanks
     
  10. bythecshore macrumors newbie

    Joined:
    Jan 1, 2008
    Location:
    CT
    #10
    I agree - awesome - I never would have connected this problem and SugarSync. I was also having this problem in Excel. VERY frustrating as there's no way to save the file because you have to force quit.

    But it still happens whenever SugarSync is active. Have you figured out to how to permanently fix it, i.e., even when SugarSync is on?
     
  11. Tony27nine macrumors newbie

    Joined:
    May 3, 2010
    #11
    Right click in Office and Sugarsync

    Anyone using Office for Mac progs such as Excel or Word and Sugarsync will have been frustrated by the computer hanging when you right click. The solution is not to Force Quit - you'll lose whatever you were doing. Just quit Sugarsync and it will sort itself out with the right click drop down menu appearing.
    If like me you often need to work on your documents or sheets later remember to re-start Sugarsync before you shut down otherwise your files won't be synced for the next time you want to use them.
    I've posted a ticket with Sugarsync but I'm sure they'll already know about the problem...
     
  12. bythecshore macrumors newbie

    Joined:
    Jan 1, 2008
    Location:
    CT
    #12
    Yes, I agree with Tony... I discovered this by accident a while back. To reiterate: if you right-click and Word or Excel freezes, just quit SugarSync, not Word or Excel. After quitting SugarSync, the program will unfreeze and you'll be back in business.
     
  13. billshander macrumors newbie

    Joined:
    May 6, 2010
    #13
    Any updates to this?

    I can't find any info on SugarSync's site to see if they are actually aware of (or working to resolve) this issue. I was so happy to find this work-around, but it would be even better to have a permanent solution!
     
  14. billshander macrumors newbie

    Joined:
    May 6, 2010
    #14
    This is solved!

    Hi Everyone,

    I got support via Twitter for this - turns out SugarSync did solve this with version 1.8.2 of the client. You just need to go here: http://is.gd/fvDIr to see what to do (just need to delete one file from your computer.)

    I've done this and it seems to have fixed the issue for me. (After nearly two years of not being able to right-click in Excel, Word or PowerPoint!)

    Bill
     
  15. Alby macrumors newbie

    Joined:
    Jan 24, 2011
    #15
    Problem Still Exists

    Thank you for posting this fix. I joined SugarSync only last week (Jan 2011) and had the problem today. When I attempted to follow the fix link shown above it lead to an error message. The quitting and re-starting of the SugarSync file manager (in the header bar NOT in your Dock bar) fixes it immediately. Thanks for all of the good information.
     

Share This Page