Word Perfect 3.5E Error saving in RTF

bunnspecial

macrumors 604
Original poster
May 3, 2014
6,723
3,276
Kentucky
I know this might be a bit out of the scope of this forum, but I figured that this was the best place of any to ask this.

I was playing around with WP 3.5E earlier today, and though I'd try saving something in RTF to check compatibility with other computers. I got the below error message when trying to do so. Saving as a WP Mac file caused no problems.

I got the same error on both my Clamshell G3 and my Pismo G3.
 

Attachments


David Schmidt

macrumors 6502
Aug 22, 2006
319
10
Southeastern USA
I'm guessing it's the ChemDraw element it doesn't like. Can you save plain text (no graphics) in .rtf with no trouble in WP 3.5E?

What if you save as WP Mac, close, load it back in, and then save to .rtf? Any difference?
 

bunnspecial

macrumors 604
Original poster
May 3, 2014
6,723
3,276
Kentucky
I'm guessing it's the ChemDraw element it doesn't like. Can you save plain text (no graphics) in .rtf with no trouble in WP 3.5E?

What if you save as WP Mac, close, load it back in, and then save to .rtf? Any difference?
I thought I'd tried all of that earlier, but did it again just to be sure.

A plain text document gives me that error, although can be saved fine as a Word Perfect Mac document.

Reopening that plain text document and trying to save as RTF does the same.
 

Attachments

MacTech68

macrumors 68020
Mar 16, 2008
2,185
149
Australia, Perth
The Corel WordPerfect 3.5e application must stay in it's folder along with the "Conversions" folder and the "Language" folder. There should also be you default language file, for example "English (USA)" file.

What System version are you running?

Are you using the installer, or drag copy?

EDIT: try moving the folder, YOURHARDDRIVE/System Folder/Preferences/WordPerfect/ to the desktop (with WP NOT running). Re-launch WP and try again.

Also, have you run the WP OS8-9 Updater over your installation?
 
Last edited:

bunnspecial

macrumors 604
Original poster
May 3, 2014
6,723
3,276
Kentucky
Both of these are on 9.2.2. I installed both using the installer. I also ran the "update" that came with the installer.

In any case, I can always try running the installer again...
 

MacTech68

macrumors 68020
Mar 16, 2008
2,185
149
Australia, Perth
Well, all I can suggest is to reinstall, but this time, try a custom install for PowerMacintosh, and chose your selected language(s).

Also, check that your initial install didn't blindly install Macintosh Easy Open v1.1.1

I can't remember if MEO is installed on 9.2.2, but the WP3.5 readme states:

Corel WordPerfect 3.5 Enhanced installs Macintosh Easy Open 1.1.1 into the active System Folder:Control Panel folder. For people using Macintosh Easy Open version 1.04 and earlier, it’s important to point out that Macintosh Easy Open 1.1.1 is now a Control Panel. Remove the old Macintosh Easy Open from the Extensions folder and the old Macintosh Easy Open Setup Control Panel from the Control Panel folder.
MEO is a pseudo translator itself so..... :eek:

Otherwise, it may come down to troubleshooting extensions. Try your 9.2.2 Only set, reboot and see what happens. (You probably should save your current set before proceeding). To make things easier, I used to remove half at a time. If the problem goes away, then it's in the half that you disabled, otherwise, disable half of the remaining ones (keep track of the ones you disable each time by moving them to new folders).

One more thing, make sure there are no odd characters in your hard drive's name. Some older programs may have routines that can't cope with them.

ANOTHER LATE EDIT: The OS 8-9 patch changes the version number to 3.5e2B0 thus:
 

Attachments

Last edited:

bunnspecial

macrumors 604
Original poster
May 3, 2014
6,723
3,276
Kentucky
Thanks-will tackle what you suggested and report back.

By the way, I'm pretty boring. Most of my computers-including these two-are just "Macintosh HD". Sometimes I'll add an extra word in to designate the system(i.e. Macintosh Clamshell HD, Macintosh Pismo HD) but never any special characters.