Word working slowly

Discussion in 'Mac Apps and Mac App Store' started by GoldenHoya, May 4, 2005.

  1. GoldenHoya macrumors newbie

    Apr 29, 2005
    Berkeley, CA
    Hey all, I'm a very recent switcher, bought a powerbook (1.5gig, 80 gig harddrive, 512 ram, 64vram) just a few weeks ago. The one thing that's been annoying me is that word is much slower on this machine than it was on my old one (a 667 pc with 256 ram). Any reason or way that I can speed it up? Would more ram really do the trick or did i screw myself by not getting the 1.67 processor when I had the chance?
    I absolutley love the pb and have to say that as far as complaints go, mine is pretty small, but one that I thought I would ask all of you about. Thanks for any help!
  2. Blue Velvet Moderator emeritus

    Jul 4, 2004
    Try turning off some of the auto-features. Grammar-checker etc.
    Font smoothing settings have also been reported to have an effect.

    IMHO, some of the eye-candy in Word 2004 is completely unnecessary and counter-productive for most users.
  3. Nuc macrumors 6502a


    Jan 20, 2003
    Mine does too.

    Yea I have the same problem. When I have a lot of equations or pictures in the document it take for ever sometimes to scroll to the end of the document. The problem is the RAM I believe, I'll be getting 1GB soon. It's not your processor speed. Microsoft hasn't optimized Office for the Mac...IMHO.
  4. GoldenHoya thread starter macrumors newbie

    Apr 29, 2005
    Berkeley, CA
    I guess that makes my next purchase more RAM. I found a site that has a 512 stick for $100, but 1 gig stick for $290. Is the 1 gig stick really worth it or will most things work fine with a gig total (as opposed to 1.5 gig)?
    I use the powerbook mainly for typing, some games, internet but not really anything more intense that than. I'm heading to law school in the fall so I'm going to be living cheap for the next few years and would like to get what will last me a long time right now (while I can afford it). Any suggestions?
  5. indigoblu macrumors member

    Apr 21, 2005
    Make sure you have the newest update from mactopia, although there hasn't been one in a several months. I noticed Word sped up and worked better with the updates after I downloaded them.
  6. motulist macrumors 601


    Dec 2, 2003
    Here's a general speed up tip for everyone. In system preferences, go to energy saver, pull down "optimize energy settings for" to highest performance.

    But be warned, don't keep it on that setting forever as it keeps the computer from going to sleep. Keeping it on highest performance all the time would shorten the life of the computer's components, and with a powerbook it will drain your battery more quickly.

    But if you're plugged in, I recommend turning on highest performance whenever you're going to be working on your computer for any length of time.

Share This Page