Wordpress and redundant 'Home' button with static page

Discussion in 'Web Design and Development' started by eyup, Feb 20, 2009.

  1. eyup macrumors regular

    eyup

    Joined:
    Aug 21, 2006
    Location:
    UK
    #1
    Hi,

    Spent half a day looking for solutions to this, google, wordpress forum - driving me nuts ;-)

    Wordpress allows you to set a Static page as the homepage - but the problem (as you peeps will no doubt have heard a million times) is that it leaves the 'home' tab in the navigation bar - which goes to the static page. See:

    http://www.a-on.co.uk/calderevents/

    This is what I've failed to find - is there a simple way to remove the 'Home' tab which applies to all templates? Or are all templates different in respect of the coding which renders the Nav system so I'd have to edit the code in each theme?

    Basically - How do i dump the 'Home' tab in the nav?

    Amazed I can't find a tutorial that covers this point - it's simply not mentioned.
     
  2. tobefirst macrumors 68040

    tobefirst

    Joined:
    Jan 24, 2005
    Location:
    St. Louis, MO
    #2
    The first place I would look based on my experiences with WordPress would be the Header.php file...towards the bottom. You'll likely have to manually edit it. Fortunately, it can be done in the browser.

    Have you looked there already?
     
  3. eyup thread starter macrumors regular

    eyup

    Joined:
    Aug 21, 2006
    Location:
    UK
    #3
    Hi tobefirst,

    Looking now - is there a specific bit of code that needs to be altered? And would this code be the same/similar in all themes?

    (ps i'm not a codehead btw ;-)
     
  4. macbookairman macrumors 6502a

    Joined:
    Jan 15, 2008
    Location:
    United States
    #4
    I'm not sure I understand 100% what you want, but this Wordpress plugin might help. We use it at the the Zym Blog (app review site, in signature)

    Plugin Description:
    Link: http://wordpress.org/extend/plugins/exclude-pages/
     
  5. eyup thread starter macrumors regular

    eyup

    Joined:
    Aug 21, 2006
    Location:
    UK
    #5
    Hey cheers.

    I've sussed a way to do it using that plug in - with one small problem: The home page button in the nav bar doesn't highlight.

    (I'll try and explain the problem better for you:

    I set a static page as the Front Page - eg Welcome.
    But there is always the original 'Home' page tab in the nav system & the Front page tab - Welcome - is highlighted.)

    Using that plug-in I can hide the 'Welcome' page in the nav bar so leaving just the original 'Home' bar - great! - but for some strange reason though we are at the Home/FrontPage - the button does not highlight.
     
  6. macbookairman macrumors 6502a

    Joined:
    Jan 15, 2008
    Location:
    United States
    #6
    OK, do you have the latest version of Wordpress?

    Also, how do you have your URL's set up? For example on my site (in signature), clicking on the "About" page in the Nav. Bar will load zymblog.appstorebeta.com/about .

    On your site, clicking a link in the Nav. Bar loads www.a-on.co.uk/calderevents/?page_id=12

    The page_id thing could be messing with the system. I'm pretty sure there is a way to turn that off. Not sure if thats whats giving you trouble, but its still something that should be fixed probably.
     
  7. eyup thread starter macrumors regular

    eyup

    Joined:
    Aug 21, 2006
    Location:
    UK
    #7
    Tried that and you end up with a standard blog type page.

    (know what you mean about wording - having a he'll of a time describing this problem ;-)
     
  8. macbookairman macrumors 6502a

    Joined:
    Jan 15, 2008
    Location:
    United States
    #8
    ahh...you quoted me too early. i changed what it says :)
    Addition to what I posted above:

    I checked my site, and I believe you should try going to Settings>Permalinks
    If its not already chosen, choose Day and Name.

    Then go to each of the pages (in the Page Editor in Admin menu) that are in your Nav Bar, and under the Page Title change the permalink to sitename.com/pagename . That will look better than that page_id stuff.
     

Share This Page