Wordpress Permalink Set-up - Mac 10.6

Discussion in 'Web Design and Development' started by superfunkomatic, Oct 26, 2009.

  1. superfunkomatic macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    calgary, ab canada
    #1
    I've been running 10.6 client as a webserver pretty much since 10.1.

    I have several sites running on my machine and I'm trying to enable Permalinks in wordpress on one of the new sites I've added. It works on two sites I've created in the past but I can't seem to get it to work on this new one. Odd?

    I've created a .htaccess file and chmod to 666, then 777, 766 - nothing seems to work.

    the .conf files are set to AllowOverride All.

    Can someone give a quick step by step on what to look for or something that I'm missing? I'm stumped :confused:

    Much appreciated.
     
  2. superfunkomatic thread starter macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    calgary, ab canada
    #2
    really? no one has run into this issue before?
     
  3. photon43 macrumors newbie

    Joined:
    Nov 3, 2009
    #3
    Permalinks Mac OS

    I can't believe nobody has run into this before and come up with a fix. I've been trying to get an answer to this for months and have had zero luck. If anyone knows of a way to get this to work, it would be of great use.

    BTW, Im running XAMPP for OS X using 10.6

    Thanks!
     
  4. photon43 macrumors newbie

    Joined:
    Nov 3, 2009
    #4
    I have an answer for you...

    I can tell you have dealt with server administartion before but I always find it helpful when people spell it out for me (also, other may need this info) so here we go...

    OK first of all you will need to be running XAMPP 1.7.2 (latest Build) or later. You can find it here with installation instructions...

    http://www.apachefriends.org/en/xampp-macosx.html

    Once you have installed it, your applications folder will have a xampp (xamppfiles inside of it too) folder with an alias to htdocs inside of it. htdocs is where you will place your root folders of any sites you are working on.

    Start your webserver by launching the XAMPP control panel and typing in your admin password.

    -----------------------------------

    Next open your httpd.config file located in applications>XAMPP>xampfiles>etc>httpd.conf

    Ensure that:
    #LoadModule rewrite_module modules/mod_rewrite.so

    Is set to:
    LoadModule rewrite_module modules/mod_rewrite.so

    -----------------------------------

    Then make sure that this looks in order as well:

    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

    ----------------------------------
    The above should look exactly like that.

    OK next create a .htaccess file using text edit or something and place it in the root directory of the site in question: applications>XAMPP>xamppfiles>htdocs>YourRootFolder
    This file should contain the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /YourRootFolder/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /YourRootFolder/index.php [L]
    </IfModule>

    # END WordPress

    ------------------------

    Notes on creating .htaccess files:
    You will need to tell the terminal to show hidden files in the Finder so you can see what you are doing.
    Open the terminal and type the following:

    defaults write com.apple.Finder AppleShowAllFiles TRUE
    (when you are done with everything, redo this with FALSE and relaunch the Finder to get everything looking normal again).

    Relaunch the Finder and you will see all your hidden files. Including the newly created .htaccess

    Now, the .htaccess can not have any file extention (.txt, .rtf) so you will need to make sure that in the Finder preferences, you show file extensions and delete it from your file. The Finder will warn you - tell it to use none (file extension).

    ---------------

    Navigate to your .htaccess file in the Finder and select it. Get info. Expand the Ownership and Permissions section and change the permissions of the file to read and write for Yourself, Staff and Everyone.

    Alternatively, you could navigate using the Terminal and type
    chmod 666 .htaccess

    ----------------

    Restart your webserver using the XAMPP control tool and login to your backend of wordpress.
    Turn Permalinks on and save changes.

    That should do it.

    Photon43
    http://www.gestaltcreations.com
     
  5. superfunkomatic thread starter macrumors regular

    Joined:
    Jan 6, 2003
    Location:
    calgary, ab canada
    #5
    I'll give your .htaccess information a try. The webserver is running fine, and the short urls work fine in other sites on the same machine - that's why I thought it was odd.
    I'll see if changing the content of the .htaccess file works - everything else is exactly as you mentioned.

     

Share This Page