WordPress write permissions problems

Discussion in 'Web Design and Development' started by dsmush, Nov 30, 2012.

  1. dsmush macrumors member

    Aug 29, 2012
    Hi I'm having problems with WordPress on localhost on my Mac. When I try to install a plugin it says it is downloading and unpacking then I get Could not create directory. I got around this by just doing it manually which worked fine but I now have a problem with a particular plugin as it says the xxxxx directory is not writable by your webserver. I'm assuming that this and the plugin issue is all down to write permissions in the OS but when I get info on the folder (Me), admin and everyone all have r+w permissions.
    Also I'm not sure if it is related but my Terminal name reads unknown-a1:1a:aa:a1:11:11:~ Name$ and when I try to cd to XAMPP it responds no such file or directory I can cd into Applications folder but the ls command doesn't even work in that folder either.

    I've been trying to figure this out for a day or two now If someone is able to help me with this that would be great.
  2. m00min macrumors 6502

    Jul 17, 2012
    When I do WordPress dev work on my mac I change the permissions on the uploads folder via the terminal, just like I'd do on a "proper" server. e.g. chmod 777 uploads. I'm not sure that setting the permissions via OSX info panel does quite the same thing.


    Not sure where plugins are saved when using the WP admin to download them as I do it manually. If they don't use uploads then you could try chmodding the plugins directory and see if it makes any difference.
  3. dsmush thread starter macrumors member

    Aug 29, 2012
    I would try this but I cannot get to the XAMPP folder using Terminal as I mentioned I can change directory into the Applications folder but cannot do anything else in there ls and cd do not work in that folder for some reason
  4. m00min macrumors 6502

    Jul 17, 2012
    Sorry, I somehow missed that. I'm using the built-in apache/php/mySQL setup, just assumed there'd be some facility for command line stuff in XAMPP.
  5. SrWebDeveloper macrumors 68000


    Dec 7, 2007
    Alexandria, VA, USA
    In OSX user finder to get to the folder, right click and get info. Make sure you (admin account) and everyone has Read and Write, but also check to make sure is not locked - a checkbox option further up.

    In terminal mode, if you can't perform a certain function such as changing into a directory you know is there, I am under the assumption you are not using your admin account OR other permissions issue. In such a case, use "sudo" before the command, i.e.:

    sudo chown -R your_account:admin /path/to/folder
    sudo chmod -R 777 your_account:admin /path/to/folder

    The 777 is for example purposes only, anyone can read/write - if you need to protect the folder use the proper chmod value or get help here as to chmod.
  6. dsmush thread starter macrumors member

    Aug 29, 2012
    Thank you this worked. I had tried the chmod previously but didn't seem to work perhaps I used it incorrectly and I didn't use chown at the time.

Share This Page