Working bootcamp turned "No bootable device"

Discussion in 'Windows, Linux & Others on the Mac' started by goodfidelity, Dec 11, 2015.

  1. goodfidelity macrumors member

    Joined:
    Nov 15, 2015
    #1
    I have a Mac PRO 1.1 running El Capitain.
    I have a bootcamp partition with Win 7 Ultimate on the same SSD as El capitain.
    I have a Samsung 850 EVO disc
    I have 3 other normal drives with various stuff on.

    After som swapping around (adding and removing) with the drives in my machine for a while putting the SSD in another slot and so on my mac partition will boot but the windows partition will not. It gives the dreaded:

    "No bootable device -- insert boot disk and press any key"

    I have also another graphics card, and that is original for my Mac. And that card was also swapped in and out during the same time.

    Now i am back to where it used to run. Same graphics, same ssd, and everything else is out.

    Strange thing is that the windows partition have not been booted during this period with swapping around the drives or graphics cards, but still now it will not boot.

    I tried zapping PRAM and choosing the bootcamp as boot partition in the system preferences. And that still does not work.

    How can i get my mac to boot on the Win7 partition again? Its a real hassle to set up a Win7 installation so i would rather avoid doing that.

    Anyone got some nice clues?
     
  2. ghislain macrumors member

    Joined:
    Apr 22, 2009
    #2
    Try to repair your bootcamp partition with your windows install dvd..
     
  3. goodfidelity, Dec 14, 2015
    Last edited: Dec 19, 2015

    goodfidelity thread starter macrumors member

    Joined:
    Nov 15, 2015
    #3
    I tried that, putting the disc for some reason gives the exact same problem.

    The partition boots fine in vm ware.

    I think this might be more of a pram problem or something that way. I am not sure.

    Hoping someone experienced the same..
     
  4. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #4
    Does it do the same if you hold Option at boot to select an OS?

    Might also try putting the Boot Camp drive in bay #1.
     
  5. goodfidelity thread starter macrumors member

    Joined:
    Nov 15, 2015
    #5
    Ok!

    Thanks man for giving the advice. I tried to put the bootcamp drive in #1 and use the OSX startup disc selector. But did not work.

    I am running a R9 280X graphicscard, so i cant see the bootscreen where to select OS. That makes it difficult to use the ALT startup feature to select disc. I tried booting with ALT and pressing ARROW RIGHT - ENTER or ARROW LEFT - ENTER to do this in the blind. But nothging happens.

    Befor it displays the text, its just a white line blinking in upper left corner for quite some time. This is normal, but usually it just jumps into WIN7 after one minute or so.

    I have the original graphics card, but not the adapter to hook it up to my screen so i cant try the OSX option to choose OS when booting.

    Maybe i have to buy another adapter.

    Is there any reason for this behaviour to occur? Why does it start? The partition was running fine in the beginning. Is it better to run Windows7 from another drive and dont use two partitions?

    //GF
     
  6. goodfidelity thread starter macrumors member

    Joined:
    Nov 15, 2015
    #6
    Ive solved the problem, but i dont know the cause. Thinking i might post my findings.

    The computer has a R9 280X graphics card that does not show boot screen.

    This makes it impossible to use the ALT bootdisc feature at startup.

    If i try to do this in the blind ( no image on screen) i know that i should hold the ALT key for about 10sec, then press RIGHT ARROW and then press ENTER. That should make the computer boot into windows.

    However, if there is no monitor attached, no image showing. This does not work for some reason.

    I simply did like this:

    Put back OLD graphics card in slot 1.

    Pull all video cables from R9 280x card.

    Connect OLD card to monitor.

    Boot with ALT key, and pick windows. And its working!

    So there is nothing wrong with the windows partition, but rather seems that something happens with the boot sequence that will not allow the Windows partition to boot unless i force it with the build in boot disc feature (ALT key) at startup.

    Even if i pick the same partition as boot disc in OSX its not working.

    So no i have to solve this by flashing the R9 280X card with a working EFI so that i get boot screen.

    Thanks for the help everybody, hope this helps someone out there.

    //GF
     

Share This Page