Workout and Stopwatch conflict

Discussion in 'Apple Watch' started by ipaddaro, Oct 12, 2018.

  1. ipaddaro macrumors regular

    Joined:
    Dec 6, 2014
    #1
    Hi,
    today i did my first workout at the gym with the AW 4.

    I started the Workout app... during the workout i need to use the stopwatch, so my intention was to let workout app stay in baground and use the stopwatch when i need it.

    The problem is that if i use the stopwatch, and then rest too much or simply to the exercise, when i rise the wrist the AW shows the workout app and not the stopwatch!
    so every time i have to click the crown, select the stopwatch on the face (because i have put the complication on the face, otherwise i should have clicked another time the crown and find the app or press the side button etc...)

    every single time!

    is it possible to avoid that workout app shows over the face or stopwatch app?
    i’d like to track my workout with the app in background, but at the moment it is quite annoying...

    i hope i managed to explain the problem
     
  2. dave006 Contributor

    dave006

    Joined:
    Jul 3, 2008
    Location:
    Just West of East
    #2
    You explained the issue correctly however that is how Apple has chosen the watch to perform. The "Workout" app when running is always forced to the foreground since you are doing a "workout". The timer / stopwatch once set can be sent to the background and will not automatically return until you take an action or in the case of the timer (it ends) and pops to the foreground for you to end or restart.

    Dave
     
  3. ipaddaro thread starter macrumors regular

    Joined:
    Dec 6, 2014
    #3
    thank you for the reply.

    Anyway, no good news... for people who train at the gym, as me, the stopwatch is fundamental. The workout app is useful to track the heart rate and calories consumption, but press the crown every time is soooo unconvenient.

    at the end, when doing rope jump, i started a tabata app that prevailed over the workout app. maybe i’d better download another stopwatch and not use the stock one...
     
  4. roncito macrumors 6502a

    roncito

    Joined:
    Apr 21, 2015
    Location:
    Poconos PA
    #4
    Have you tried going to settings on the Apple Watch app on your phone? Go to general>wake screen> look under on screen wake show last app. What do you have set for that?
     
  5. DesertSilver macrumors 6502

    Joined:
    Aug 18, 2011
    Location:
    Portland, OR
    #5
    This same thing happens with the Nike Run Club app. During an NRC run, if you have something else on the screen, even just the regular watch face, the NRC app displays again after a minute or so when checking the screen. I've tried different wake screen settings but seems that workout apps override everything and becomes active.
     
  6. ipaddaro thread starter macrumors regular

    Joined:
    Dec 6, 2014
    #6
    i have set “within 2 minutes” (it’s a translation from italian, donkt know if the same words are used). but i swear it happens before 2 minutes because my rest is tipically 1:30...anyway i can try to set “forever” when training and see..

    thank you for the suggestion
    --- Post Merged, Oct 12, 2018 ---
    so bad... BUT with “hit and tabata” app opened, for example, it doesn’t happen.

    maybe workout have the priority only on apple (or nike who is a partner) apps... just guessing...
     
  7. roncito macrumors 6502a

    roncito

    Joined:
    Apr 21, 2015
    Location:
    Poconos PA
    #7
    Try the always.
     
  8. ipaddaro thread starter macrumors regular

    Joined:
    Dec 6, 2014
    #8
    i’ll try!
     

Share This Page

7 October 12, 2018