Workouts not syncing to iPhone app?

Discussion in 'Apple Watch' started by Ideanj, Oct 23, 2017.

  1. Ideanj macrumors member

    Joined:
    Apr 30, 2013
    #1
    Hi everyone,

    Ever since updating to WatchOS 4 and iOS 11, I've noticed random work outs have stopped syncing to my phone. Earlier today I did a 2 mile run and while the Workout circle filled up and recorded the workout, the actual workout was not recorded/synced to my iPhone and I am only able to see a 1 mile walk I did this morning. This happened again last Friday too.. It's a strange issue. Has anyone else experienced this problem?
     
  2. mk313 macrumors 6502a

    Joined:
    Feb 6, 2012
    #2
    No idea what’s going on but I had the same thing happen to me this morning. Went on a run using the work out app, saved it, hit done on the run details page that popped up, and then the run never showed up on my phone when I checked later.
     
  3. davids8477 macrumors 6502

    Joined:
    Jan 4, 2008
    #3
    Same here with a cycle ride - worked for the previous 6 days but stopped today .

    Series 3 with latest Watch OS
     
  4. Ideanj thread starter macrumors member

    Joined:
    Apr 30, 2013
    #4
    I ran on Wednesday and it was a little delayed but it showed up. I just finished running 2.5 miles right now and again, it failed to sync to my iPhone. Are your exercise rings still filling? This is really frustrating.

    I will note that the average heart rate didn’t generate like normal when I was on the workout details page. I’m wondering if you hit done before that finished calculating it fails to sync to the phone... idk just speculating
     
  5. mk313 macrumors 6502a

    Joined:
    Feb 6, 2012
    #5
    My exercise rings are still filling, even while the exercises themselves disappear
     
  6. davids8477 macrumors 6502

    Joined:
    Jan 4, 2008
    #6
    Exercise ring did not fill, the workout was totally missing.
    I may have hit the done ring too soon, don’t know.
    Has not happened again - yet.
     
  7. Bbafett macrumors 6502

    Joined:
    Sep 14, 2012
    Location:
    Georgia
    #7
    Try restarting phone and watch. I have had that issue before.
     
  8. Craiguyver macrumors member

    Craiguyver

    Joined:
    Jan 26, 2013
    Location:
    Minnesota, USA
    #8
    I've been having some issues with exercises not registering on the activities rings. If I restart my watch and phone, it seems to temporarily resolve it. But then the issue randomly occurs again after a period of time. No idea what's triggering it, but I've only been noticing it since the watch 4.1 update.
     
  9. Bob190 macrumors 6502

    Joined:
    May 21, 2015
    #9
    Exactly why I only use the built-in Workout app for swims. I was having the same issue with runs not syncing occasionally. I have been using the Strava app for some time now and never have that issue.
     
  10. ddrulez macrumors regular

    Joined:
    Dec 12, 2012
    Location:
    Germany
    #10
    Same here. Last days it was ok. After the IOS 11 hotfix yesterday night it wasn’t sync my workout data today.
     

Share This Page

9 October 23, 2017