World of Warcraft lockups on SR MBP SOLVED!

Discussion in 'Mac and PC Games' started by kinetik, Jul 19, 2007.

  1. kinetik macrumors newbie

    Jun 8, 2007
    I can't remember the post where I originally saw this, but doing the following seems to have fixed my lockup and stuttering issues on my 2.2ghz Santa Rosa Mac Book Pro:

    + all shaders off
    + distance to just-under halfway
    + 1x sampling
    + AF to the lowest setting
    + vertical sync off
    + full screen glow off

    Now I'm getting ridiculously good framerates (up to 150 inside! around 30-50 outside), with rarely any stutter (practically zero) when spinning the camera or rotating in place.

    Also, it seemed to perform better by NOT using /console maxfps to limit the framerate. It was as if having the larger FPS pool allowed WoW's framerate dips to not fall into a noticeable range. (for example, a dip from a maxed 30 FPS cap to 10 is much more noticeable than a dip from 80 to 30) The obvious upside of not limiting the FPS is smoother gameplay. (I had previously tried this to limit heating which I thought was my problem)

    Crossing my fingers that these settings really did fix it, but I played for several hours with no issues. In the past, I couldn't get through an hour without a lockup.

Share This Page