World of Warcraft & my Video settings

Discussion in 'Mac and PC Games' started by getatkyill, Jan 18, 2010.

  1. getatkyill macrumors regular

    Joined:
    Oct 10, 2008
    Location:
    Taunton, MA
    #1
    Hello everyone,

    So I just got World of Warcraft installed, was able to get my account set up and jump into one of the servers (realms). Only thing I noticed is that the gameplay/my movement is really sketchy and laggy, almost like my mac cannot support the video settings.

    Now, I'm using the mid-range Macbook Pro with 4GB of RAM, 256MB mb of graphics geforce..I have 320GB of HDD, 2.66 GHz Intel Core 2 Duo processor & I definitely meet the requirements because I played on a PC that didn't have as great settings and worked better than the mac settings.

    Umm..i've never played a computer game on the mac side, usually just bootcamp over to windows but since WoW is available on mac I obviously rather have it on the snow leopard OS.

    So if anyone could point me in the right direction on what to do to fix this & so my WoW can run smoothly, I'd greatly appreciate it!

    Thanks in advance.
     
  2. roliath macrumors regular

    roliath

    Joined:
    Dec 7, 2009
    Location:
    dallas
    #2
    Take a look at this thread, http://forums.worldofwarcraft.com/thread.html?topicId=4028094861&sid=1.

    I have the same macbook pro as yours except I have an SSD and my Wow runs really well considering the gpu. I'm running the settings listed in that thread.

    Also, to note i'm running the MAC client.
     
  3. juliancs macrumors 6502

    Joined:
    Aug 24, 2006
    #3
    Take off multisampling, turn environment, weather and ground clutter radius to minimum, turn down particle density. Turn down terrain blending as well.
     
  4. colocolo macrumors 6502

    Joined:
    Jan 17, 2002
    Location:
    Santiago, Chile
    #4
    FWIW, I have the same MBP as you but with the 512MB video card.
    Before the 3.3 patch, I could play with everything on high, and the performance was still better than with my old MBP (late 2007, 128MB VRAM).
    After the patch, I had to lower the settings quite a bit and still get some chippiness in some areas (mainly Dalaran).

    So, it has to do more with the patch than with your computer.
    I had to suck it up and lower the settings, while we wait for patch 3.3.x or an update to OpenGL in 10.6.x to take care of this particular problem.
     
  5. atarria macrumors member

    Joined:
    Oct 4, 2009
    #5
    open GL problem

    Its OpenGl thats killing your frame rate not a problem with your computer.
    The answer to this is in post "WOW, patch 3.3 has some serious OpenGL problems.":apple:
     
  6. James Craner macrumors 68000

    James Craner

    Joined:
    Sep 13, 2002
    Location:
    Bristol, UK
    #6
    As the previous poster said this is a know problem for Mac users since patch 3.3. Happily there is a simple fix to revert back to the old open GL graphics engine.

    Open your Config.wtf file that is found in your WTF folder in World of Warcraft folder in Applications and add the following at the bottom

    SET gxapi "OpenGL"

    Save and restart wow and you should be fine.
     
  7. xizar macrumors regular

    Joined:
    Dec 17, 2009
    #7
    I *just* got a Macbook and threw WoW on it and have been very surprised at how well it runs. Granted, it ran like crap before I upgraded the RAM to 4gigs, but since then, it's awesome. With only 2gigs, I could barely do *anything* other than farm rep for Sons of Hodir and other solo activities.

    The only settings I changed from the default WoW install were to remove Full Screen Glow and the Death Effect. I also dropped weather down to the penultimate setting.

    I get about 30FPS in Dalaran during the day.

    That being said, I eagerly anticipate the arrival of my 27" i7. :)

    (As an aside, playing WoW with just the touchpad is horrid.)
     
  8. ooninay macrumors member

    Joined:
    Mar 19, 2009
    Location:
    Toronto
    #8
    This may be too obvious but are your Power Saving settings (OS X System Preferences) set to maximum battery life instead of maximum performance? Because if so it will kill your WoW performance.
     

Share This Page