World of Warcraft on Bootcamp problem!

Nickols12345

macrumors newbie
Original poster
Jul 11, 2010
11
0
Hey. I just finished patching WoW Wotlk on my MBP. But when I try to open the application it says "Failed to find a suitable display device. Exiting program.". If you need the macbook specs to give me a solution, they are on my signature. Plus i'm running windows 7 ultimate 64-bit. Any suggestion? :D
 

jakeguy99

macrumors regular
Jan 21, 2007
201
1
Which graphics card are you using. If nvidia i would go to their website and properly update the drivers. make sure your system is up to date and all drivers are properly installed through the mac OSX install disc. Then go to the website and update your graphics drivers even further.
 

Nickols12345

macrumors newbie
Original poster
Jul 11, 2010
11
0
Which graphics card are you using. If nvidia i would go to their website and properly update the drivers. make sure your system is up to date and all drivers are properly installed through the mac OSX install disc. Then go to the website and update your graphics drivers even further.


Yes, I am using Nvidia Geforce GT 330m. I thought that the installation of the drivers were the problem. So I uninstalled 64-bit and installed 32-bit. Then I properly install the drivers then went to apple.com and downloaded 32-bit 3.1 bootcamp. But still I can't run WoW, nor any other game. I've tried Avatar, Age of Mythology, Civilization IV and of course WoW. None of these run.

Avatar is not responding
Civ IV pops up an error
Age of Mythology plays the main menu music but nothing appears on the screen
WoW gives me an error too.

I don't know what's going on, on my iMac, I have the same edition of Windows with all the drivers installed and it runs every game!

Any advice?
 

Gepper

macrumors member
Dec 7, 2009
79
0
Yes, I am using Nvidia Geforce GT 330m. I thought that the installation of the drivers were the problem. So I uninstalled 64-bit and installed 32-bit. Then I properly install the drivers then went to apple.com and downloaded 32-bit 3.1 bootcamp. But still I can't run WoW, nor any other game. I've tried Avatar, Age of Mythology, Civilization IV and of course WoW. None of these run.

Avatar is not responding
Civ IV pops up an error
Age of Mythology plays the main menu music but nothing appears on the screen
WoW gives me an error too.

I don't know what's going on, on my iMac, I have the same edition of Windows with all the drivers installed and it runs every game!

Any advice?
Have you tried running it in OS X?
 

senc01a

macrumors regular
May 31, 2007
165
0
You have not installed the proper video drivers.
Reinsert the DVD 1 that came with your macbookpro on windows and run the installer.
If you've already done and it still doesn't work go to http://www.nvidia.com (supposing you have one of the newest laptops), download the appropiate drivers, install them and restart.
That should work!

Good luck!
 

Nickols12345

macrumors newbie
Original poster
Jul 11, 2010
11
0
Have you tried running it in OS X?
That's what I am doing right now. But Spore, Sims 3 and The Movies do work on OS X. So It's probably a software problem.

If you've already done and it still doesn't work go to http://www.nvidia.com (supposing you have one of the newest laptops), download the appropiate drivers, install them and restart.
That should work!

Good luck!
I'm going to install the nvidia drivers and I'll see if it works. If it doesn't, I will proceed with a reinstallation of windows and see what I can do. If it does work, I'll still proceed with reinstallation of windows, to see if drivers for 64-bit windows work.

Thanks :D
 

Plutonius

macrumors G3
Feb 22, 2003
8,413
7,285
New Hampshire, USA
Hey. I just finished patching WoW Wotlk on my MBP. But when I try to open the application it says "Failed to find a suitable display device. Exiting program.". If you need the macbook specs to give me a solution, they are on my signature. Plus i'm running windows 7 ultimate 64-bit. Any suggestion? :D
Why bother, just run it in OSX . You might get a few more fps in windows but you will not notice the difference in WoW.

No idea though why it will not run in bootcamp. The Worldofwarcraft forums are great and should be able to help.
 

Nickols12345

macrumors newbie
Original poster
Jul 11, 2010
11
0
Thank you everybody! I found what I did wrong! I installed outdated drivers from last years' Snow Leopard disk instead of the leopard disk which came with the macbook. So I could install 64-bit. I feel so embarassed :rolleyes:. Anyway, everybody thanks for your help, I appreciate it :D



Why bother, just run it in OSX . You might get a few more fps in windows but you will not notice the difference in WoW.

No idea though why it will not run in bootcamp. The Worldofwarcraft forums are great and should be able to help.
Well, I prefer not to occupy much of the OS X partition with games.
 

Similar threads

  • Jacobis99
8
Replies
8
Views
242
  • Huntn
4
Replies
4
Views
129
  • maflynn
20
Replies
20
Views
3K
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.