Worried it's more than a usb problem

Discussion in 'Mac Basics and Help' started by kj50state, Nov 8, 2012.

  1. kj50state, Nov 8, 2012
    Last edited: Nov 8, 2012

    kj50state macrumors newbie

    Apr 23, 2008
    On a macbook pro 17" running 10.8.2

    Trying to save to a memory stick that has been formatted as Mac OS Extended (Journaled).

    I'm not able to save anything to it. I fear it's a problem with my mac as Drive Genius 3)just showed an error last week. The error went away after disk utility permissions repair, but saving to a USB still isn't possible.

    The below images might help with your assessment... The same message is given regardless of item saved. I recently reformatted my usb to no avail. Before I erased it, the info for it was created in 1970 Jan. 1st. weird

    Attached Files:

  2. AppleMacFinder macrumors 6502a


    Dec 7, 2009
    Do you have any other USB sticks? Have you tried them?

    By the way, 1970 January 1st is UNIX Epoch, nothing weird. Probably the date was corrupted, and reset to defaults.
  3. kj50state, Nov 8, 2012
    Last edited: Nov 8, 2012

    kj50state thread starter macrumors newbie

    Apr 23, 2008
    Yes, I have tried 3 different ones. Same message for all of them. The USB's do work on other machines.


    I have borrowed another USB from a coworker. His works fine.

    The 3 of mine no longer work properly on other computers. I can save to them, but after that I cannot open up the documents from them.

    So... It is USB problems. Any reason why all three of mine would go bad overnight?

Share This Page