WoW and the new Imac performance problems

Discussion in 'Mac and PC Games' started by luffytubby, Jun 21, 2008.

  1. luffytubby macrumors 6502a

    luffytubby

    Joined:
    Jan 22, 2008
    #1
    Hello! I just recently got my iMac(YAY!!!) and am very happy with it so far, but at highest settings in Wow I get around 22 FPS at default!

    My Imac has 4 Gigs of Ram, 1 TB Hard drive and a 3 GHz CPU and an 88800 GS!


    I updated all the things I could from the apple updater but was wondering if I also needed to update the graphics card manually like on pc`? I dont understand why the performance is so low, compared to desktop computers I have had that could run WoW fluently at highest settings much better.
     
  2. Sijmen macrumors 6502a

    Joined:
    Sep 7, 2005
    #2
    I've read that there are some problems with full screen glow. Does it help anything to disable it?
     
  3. nephilim7 macrumors regular

    Joined:
    Jun 13, 2008
    #3
    there are issues with 10.5.3.. I personally lost about 20fps on my macbook pro, so now I run it in bootcamp rather than rolling back to 10.5.2

    check out the wow apple support forums for details on this issue.
     
  4. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #4
    I'm willing to bet your problem is your Multisampling. Set it to 24-bit color 24-bit depth 1x Multisample and your framerates should increase accordingly.
     
  5. Vster macrumors 6502

    Joined:
    Jan 19, 2005
    Location:
    Celina, TX
    #5
    Sweet idea! I need to try that on my MBP. I get between 15-22 fps so I hope this works! :)
     
  6. cluthz macrumors 68040

    cluthz

    Joined:
    Jun 15, 2004
    Location:
    Norway
    #6
    I get a lot better fps tha u guys on my MBP, but then again i'm still on 10.5.2

    Here's a pic from doing a timetest from IF to SG, ofc i don't have that much FPS while in outlands tho
     

    Attached Files:

  7. MikeMaximus macrumors newbie

    Joined:
    May 28, 2008
    #7
    I was having frame rate problems with my new iMac too. Turn off the "Full Screen Glow" effect and that will fix it.
     
  8. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #8
    I typically get around 80-120 frames per second in WoW with everything maxed except Multisampling, but then again, I'm playing on a Mac Pro. Still, setting it to 1x instead of 2x or higher has always given me higher framerates. Turning off Full Screen Glow doesn't affect much anymore, the later updates to WoW make it less of an issue.
     
  9. HiRez macrumors 603

    HiRez

    Joined:
    Jan 6, 2004
    Location:
    Western US
    #9
    Just got my new 3.06 GHz + 8800GS iMac too. I think it must be Full Screen Glow causing the problem because I have everything maxed, including multisampling at 4X, and 1920x1200 resolution and I'm getting around 50-65 fps. With settings turned down just a little I can easily get over 150 fps. It's beautiful, I've never seen WoW look this good. Full Screen Glow has always had terrible performance on any Mac, so I always keep it off. The effect is nice, but not worth slaying your frame rate for.

    Also, even though I'm getting 50+ fps now, I still use /console maxfps 30 to leave some of my CPU free for other things, the game is still buttery smooth.
     
  10. capple macrumors newbie

    Joined:
    Jun 21, 2008
    #10
    shoud have been fine

    people suggest turning off full glow but 8800 gs and 3.X GHz should easily be able to max out WoW and still get over 60 fps. Ive had the exactly the same imac you have for about a week and WoW fps at 1900 X 1200 never dropped below 60 UNDER WINDOWS. Yes, performance isnt exactly the same under OS X but I would have been shocked to find out minus 40 fps or more. I wonder if other people have the same issue...
     
  11. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #11
    This is a driver issue. Its doesn't matter what the hardware is capable of.
     
  12. MoGa macrumors newbie

    MoGa

    Joined:
    Jun 24, 2008
    #12
    Same trouble.. but are they going to fix it?

    ... well the title says it all... Are the powers that be going to fix this? or do we have to sink so low as to "bootcamp" our way out of our misery? :confused:
     
  13. JavierP macrumors regular

    Joined:
    Mar 17, 2008
    #13
    I really hope that 10.5.4 fixes this issue. 10.5.3 broke urban terror and wow for nvidia cards :mad::mad::mad:
     
  14. thomanjones macrumors regular

    Joined:
    Dec 26, 2006
    Location:
    DC
    #14
    Try this:

    Beyond what was mentioned in the patch notes, there is a new experimental performance tweak in WoW 2.4.2 on MacOS X which you can try out - it should improve performance when using a combination of full screen glow and multisampling, which has been a suboptimal combination in the Mac client for some time.

    To enable it:

    a) quit out of the game

    b) edit the config.wtf file (edit the one in the WTF folder next to the 2.4.2 application, not the one in the parent 2.4.1 folder)

    c) add the following line
    SET AllowMultisampleFBO "1"

    d) run the game with full screen glow and multisampling enabled.

    The name might lead you to believe that the game is using the OpenGL "FBO multisample" extension, which is not yet actually available on OS X; this switch activates a new path in the WoW code which still uses the existing FBO and multisampling support in the OS, but in a more optimized way.

    This option will be on by default in WoW 2.4.3.

    Source: http://forums.worldofwarcraft.com/t...8E1232FB43E.app05_05?topicId=6136345365&sid=1

    For Performance settings in general, check out this awesome (imo) thread: http://forums.worldofwarcraft.com/thread.html?topicId=4028094861&sid=1
     
  15. Mackilroy macrumors 68040

    Mackilroy

    Joined:
    Jun 29, 2006
    #15
    It's not FSG. Trust me, turn down multisampling and you'll see huge framerate improvements.
     
  16. alexlin9008 macrumors newbie

    Joined:
    May 20, 2008
    #16
    WoW

    Hmm... My WoW seems to work fine, and I have 10.5.3. No matter what my settings are, it plays as well as any pc, and bootcamp. I didn't have to change anything.
    If you still have the installer folder (WoW-2.0.0-enUS-Installer and WoW-BurningCrusade-enUS-Slim-Installer for my computer), delete the WoW folder that has the game in and reinstall it with those installers. Make sure to move the patch installers out the WoW folder too, then move them back in after you reinstall it.
    By the way... Your WoW interface looks very, very strange.
     
  17. IanC macrumors regular

    Joined:
    Jan 29, 2005
    Location:
    Essex
    #17
    Plays great for me on my iMac. Most of the settings are around middle to high, with the yucky full screen glow effect off (Just didn't like how it looked with it on, plus of course theres the FPS gains). Average FPS seems to be around 100, sometimes as high as 160. Even hit 200 once, but that was a rarity.

    Oh and resolution is the native for the screen (20" iMac).

    I have heard thats theres problems with 10.5.3 and Nvidia cards.
     
  18. MoGa macrumors newbie

    MoGa

    Joined:
    Jun 24, 2008
    #18
    nopes...!

    Didn't work for me... still only got 19 fps outside... were strange... and sad :-(
     
  19. thomanjones macrumors regular

    Joined:
    Dec 26, 2006
    Location:
    DC
    #19
  20. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #20
    I have to say I was hesitant to even install 10.5.3 because of the WoW issues. But the guys at Blizzard at least narrowed it down to the NVIDIA drivers so I installed the update. If you don't have a Nividia card, WoW should be fine with no change in your framerates.
     

Share This Page