WoW Error Message - Exit Game Causes Screen Freeze

Discussion in 'Mac and PC Games' started by Vster, Jun 27, 2008.

  1. Vster macrumors 6502

    Joined:
    Jan 19, 2005
    Location:
    Celina, TX
    #1
    I recently purchased an iMac 3.06 w/4 GB RAM and installed WoW on it. It runs AMAZING! I get upwards of 200+ FPS (sometimes). Anyway, when I log off or "exit game" from a town or inn the screen freezes, but the mouse pointer can still move around and I can still hear the "mac error" beep. Cmd-Shft-Esc only works after a minute and then the screen returns to Finder. So, I tried logging off and exiting from the main menu and same thing except the screen is black. Then I tried it again, this time I Cmd-M'd the window to be in window mode and logged and got this error message...

    [​IMG]

    The screen resolution is 1920 x 1200 in game, and the RAM is from Crucial but is the same Samsung brand that I had pulled out. Please help! :eek:
     
  2. thomanjones macrumors regular

    Joined:
    Dec 26, 2006
    Location:
    DC
    #2
    Source: http://forums.worldofwarcraft.com/thread.html?topicId=6441116352&sid=1

    Read the whole thread for more info, but here's the gist of it:

    This is a post to inform that certain Mods, even though they are the latest update can cause Assertion Failed! errors. Please add any Mods that you have found to cause this. I will keep this list updated.

    Presently I have found this Mod and the error:

    QuestHelper 0.46.1-c8efe68 vers. 2.4.0 :
    Assertion Failed! CDataAllocator@0x00eb0ae8: leaked 1:/Volumes/..../Wow_8278patch2.4.2/.../CDataAllocator.cpp
    (after you exit out of the game)


    To fix the issue: With the game closed please delete the CACHE folder and move your WTF and INTERFACE folders out of your World of Warcraft directory. The default location is in Applications. Moving them to the desktop makes it easy to replace them if necessary.

    Test the game, if it's working fine, test the game with one Mod at a time, to see which one is causing the issue.

    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

    If NO AddOns are being used an Assertion Failed! error usually will mean that there are corruptions from within the game and will therefore need to be fully uninstalled and then reinstalled:

    In order to remove World of Warcraft safely from your system, you will need to:

    1. go to Mac HD/Applications folder and move your World of Warcraft to the Trash
    2. go to your Mac HD/Users/Shared folder and move the Blizzard folder to the Trash
    3. empty Trash
    4. Install World of Warcraft, then Burning Crusade, then download and install the patches
     
  3. Vster thread starter macrumors 6502

    Joined:
    Jan 19, 2005
    Location:
    Celina, TX
    #3
    Thanks for the help. Looks like I'll be reinstalling. :(

    Also sorry if this was a repost. I searched and couldn't find it.
     
  4. dotcomlarry macrumors regular

    Joined:
    Jul 16, 2002
    Location:
    Akron, PA
    #4
    I had this same problem (or very, very similar) and it was remedied simply by removing the QuestHelper folder from the AddOns directory. Everything worked fine afterwards.
     
  5. crkfc macrumors member

    Joined:
    Nov 11, 2003
    #5
    no need to reinstall. i still use that addon. if you exit while in full screen mode, you might hang on a black screen. if you do, just hit the return key a few times to get through the unseen error messages and you'll be fine. i wouldnt worry about this. i've played with questhelper for a while now and nothing adverse other than the message happens.
     
  6. merc669 macrumors 6502

    merc669

    Joined:
    Jun 7, 2006
    Location:
    Southern MD, USA
    #6
    Somewhere I read that when 2.4.3 comes out that is supposed to correct it. Also if you are using "WOWMatrix" to update your addons then it also comes up with a warning that questhelper causes the problem and supposed to be corrected in the next update.

    Bill....:apple:
     
  7. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #7
    I just started using questhelper and love it--all I really do on WoW is quests so the helper is perfect for me. It definitely causes the assertion error. I don't run WoW full screen and it doesn't really seem to cause any adverse action as far as game play--or OS stability--is concerned--so I will keep questhelper and hope that Blizzard fixes the problem in their next update.

    If you run full screen, hitting return twice should clear the assertion error warnings and allow the game to close.
     
  8. xoxonene macrumors newbie

    Joined:
    Jul 23, 2008
    #8
    wow assertion failed message during boss fights

    I've read several posts about assertion failed errors occuring when people exit world of warcraft but my mac doesnt get these, for some reason i get these errors during boss fights like Archimonde in Hyjal, or any boss in any instance. It forces me to logout but since im in combat i just keep getting the error message over and over with about 1.5 seconds in between each message. I play on a private server and have spoken to several GM's about the issue all they could come up with was that my interface was screwed up so ive reinstalled 3x now, and i delete the interface, cache and wtf folders before i play almost every time and i still get the same message's over and over. So i checked forums all over the web trying to find a solution, i found one such that said my interface could possibly be outdated and that i need to replace it with a newer version. So i went to http://wow.curse.com/downloads/addons/ and downloaded a new version but to no avail. This is EXTREMELY frustrating, i dont want to reinstall again knowing that there will be no change, but it appears that i have to. Can ANYONE help me please??? I cant find anyone with similar problems or any solutions to this annoying error. I dont know what else to do! please if you have ANY suggestions or solutions feel free to email me or reply on this forum, my email is xoxonene@gmail.com. :apple: thanks :confused:
     

Share This Page